summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-11 00:55:45 +0000
committerMichał Górny <mgorny@gentoo.org>2020-09-11 09:17:17 +0200
commit14bd227cf9538e33989a0a7a190995435b3633eb (patch)
tree2cce1a5038fe31566752633a3844a8ae3f20a008 /dev-python
parentsci-mathematics/z3: Bump to 4.8.9 (diff)
downloadgentoo-14bd227cf9538e33989a0a7a190995435b3633eb.tar.gz
gentoo-14bd227cf9538e33989a0a7a190995435b3633eb.tar.bz2
gentoo-14bd227cf9538e33989a0a7a190995435b3633eb.zip
dev-python/nest_asyncio: new package
Dependency for dev-python/nbclient (also new). Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nest_asyncio/Manifest1
-rw-r--r--dev-python/nest_asyncio/metadata.xml13
-rw-r--r--dev-python/nest_asyncio/nest_asyncio-1.4.0.ebuild18
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/nest_asyncio/Manifest b/dev-python/nest_asyncio/Manifest
new file mode 100644
index 000000000000..78d038457a4b
--- /dev/null
+++ b/dev-python/nest_asyncio/Manifest
@@ -0,0 +1 @@
+DIST nest_asyncio-1.4.0.tar.gz 7053 BLAKE2B e9bdfa53f8a94ddbfd87b638962b5281aa3e8830c75a019d66d8275eb107aa7268d7f5aa24782d648a5fcfbfc4e1040abf2f2f0ca5678a513a95111d293eb055 SHA512 6a5130938baabafba30c4d5435276d33aa5df5e52a84e5646de55ab64bc01d3b69340b725b74dbe3dd158d5fba8db1470a322bdcdc3b75aa1a121076e3553a06
diff --git a/dev-python/nest_asyncio/metadata.xml b/dev-python/nest_asyncio/metadata.xml
new file mode 100644
index 000000000000..31536e562ab6
--- /dev/null
+++ b/dev-python/nest_asyncio/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <description>Python</description>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">nest_asyncio</remote-id>
+ <remote-id type="github">erdewit/nest_asyncio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nest_asyncio/nest_asyncio-1.4.0.ebuild b/dev-python/nest_asyncio/nest_asyncio-1.4.0.ebuild
new file mode 100644
index 000000000000..b89a9cafeae7
--- /dev/null
+++ b/dev-python/nest_asyncio/nest_asyncio-1.4.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Patch asyncio to allow nested event loops"
+HOMEPAGE="https://github.com/erdewit/nest_asyncio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests setup.py