summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-07-17 02:28:24 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-07-16 21:03:16 -0400
commit16496fd01fd7d432935ac1d537b57b2c52cc6a0f (patch)
tree9bcf8271ae142a9416f39027796e392764a912a6 /dev-python
parentdev-util/kbuild: Add missing texinfo dependcy, bug 572160 (diff)
downloadgentoo-16496fd01fd7d432935ac1d537b57b2c52cc6a0f.tar.gz
gentoo-16496fd01fd7d432935ac1d537b57b2c52cc6a0f.tar.bz2
gentoo-16496fd01fd7d432935ac1d537b57b2c52cc6a0f.zip
dev-python/jaraco-collections: bump to 1.4
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-1.4.ebuild59
-rw-r--r--dev-python/jaraco-collections/metadata.xml2
3 files changed, 61 insertions, 1 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index de2cc2b413ce..6d343ecf7702 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1,2 +1,3 @@
DIST jaraco.collections-1.3.1.tar.gz 8616 SHA256 27e3d67f94372d70be25f46a48796441ca719aedbd4a411835e71e88455bbe66 SHA512 812fbb66543e204f09f4dc35fc43888b3e8e1cbbf4a2a0e75a0589286e1ee5b303dc30b93696d8fc952bb3dddab95d8ed5ddb09ad4511ad4e12069fb87a93386 WHIRLPOOL c8730e3bd1eb1950b523ce62e31f7e2d2fd46bacdcacd7c57b9b55f95cff51e025e47813af1777d362f83401822a4015fdd386e977bbbd26f9c1a130ff7aa65a
DIST jaraco.collections-1.3.2.tar.gz 8965 SHA256 8587fcfa89d81d639687184502cddb4868e3dc5b9a73827ee2bfe8455ab27e57 SHA512 2369e9194fba5b25294ff5977def201b14d1ae72ddce08b5163995fcb530e55046f24354a0144f9272e822c38b468f493f262d56d2d0f6edab315be90f5fca70 WHIRLPOOL adb24717b71bce2f4d4ccae216eb9fd638bd8457a6c465c73fff32e045900ca08e8cc3a2bd49e9f55f6d7897caaae2894a74c10eac343c40498e7ab2a18c712a
+DIST jaraco.collections-1.4.tar.gz 9615 SHA256 82af38e4f8ef59ef5b44738561dd766f944e145a7ce39751744783f70f779ccb SHA512 dbb7c07bd6a7b4ef41aad1fef55b760447c94aea7036b56ed6fc02deba0720c2cb644fa47598f3997a307343dd1672d4afdd745fad3e02e37257ea714c02634a WHIRLPOOL 05c22e5b1c0d3725c4f0f486ff628991103643264c0e3338172d585be155eb2ba509182b652ed5484cd07cad13b0486829df2e8e9abd5450d7417ffb19d491f4
diff --git a/dev-python/jaraco-collections/jaraco-collections-1.4.ebuild b/dev-python/jaraco-collections/jaraco-collections-1.4.ebuild
new file mode 100644
index 000000000000..7f21126bbb07
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-1.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+PDEPEND="dev-python/jaraco-text[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ if use test && ! has_version "dev-python/jaraco-text"; then
+ die "Ensure dev-python/jaraco-text is installed or the" \
+ "test suite will fail"
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jaraco-collections/metadata.xml b/dev-python/jaraco-collections/metadata.xml
index 87a0d37d3a1d..d8c47ebe79d0 100644
--- a/dev-python/jaraco-collections/metadata.xml
+++ b/dev-python/jaraco-collections/metadata.xml
@@ -4,7 +4,6 @@
<maintainer type="person">
<email>sautier.louis@gmail.com</email>
<name>Louis Sautier</name>
- <description>Proxied maintainer; set to assignee in all bugs</description>
</maintainer>
<maintainer type="project">
<email>proxy-maint@gentoo.org</email>
@@ -13,5 +12,6 @@
<upstream>
<remote-id type="pypi">jaraco.collections</remote-id>
<remote-id type="github">jaraco/jaraco.collections</remote-id>
+ <bugs-to>https://github.com/jaraco/jaraco.collections/issues</bugs-to>
</upstream>
</pkgmetadata>