summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-03 21:12:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-03 21:12:57 +0200
commit1e403a0ae16549ba6be36c1d4d2737cc07f62fcf (patch)
tree2a6afe92980f6a65e91d8e37ff102faa367744a1 /dev-python
parentdev-ml/zmq-lwt: fix build-breaking dep mistake (diff)
downloadgentoo-1e403a0ae16549ba6be36c1d4d2737cc07f62fcf.tar.gz
gentoo-1e403a0ae16549ba6be36c1d4d2737cc07f62fcf.tar.bz2
gentoo-1e403a0ae16549ba6be36c1d4d2737cc07f62fcf.zip
dev-python/frozendict: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/frozendict/Manifest1
-rw-r--r--dev-python/frozendict/frozendict-2.3.7.ebuild38
2 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/frozendict/Manifest b/dev-python/frozendict/Manifest
index bb06e4d2efa6..408059af09b7 100644
--- a/dev-python/frozendict/Manifest
+++ b/dev-python/frozendict/Manifest
@@ -1,2 +1 @@
-DIST frozendict-2.3.7.gh.tar.gz 309663 BLAKE2B 108b27039ccf3c1ce9e002b7e459689a13a3f180c8f1da48373447bd19e2c937741df6a7173481a6a1f9441df5a30dd5c7f9394d83ae69e44022010bc199c0f3 SHA512 1f34e14a494c687be54ff8b40bc6c2fd329ddd4599fdfe940c96ef1df68e7b4bb88f3b6e1bbf7043ee403d091c4ab77062eb36e5fde4b4addc1762ed64f183b4
DIST frozendict-2.3.8.gh.tar.gz 310193 BLAKE2B e21d278396bcc10d88dbc6d33c86027308f66c8de84015d1aa186f1f34e74e4be7c915459a694597e277aab0eaaa78fb716e51e5c0f9fba58bb1e8b8d22394bd SHA512 17f610fc12138446908dbd425b8b15d2b6b7d8ad2b41f68b9a03acbd096d173994049b86169c62b51732cacf1e19de77e58cd38edf3422413269bd9e4eb5ca6d
diff --git a/dev-python/frozendict/frozendict-2.3.7.ebuild b/dev-python/frozendict/frozendict-2.3.7.ebuild
deleted file mode 100644
index 6e63dc4f6e80..000000000000
--- a/dev-python/frozendict/frozendict-2.3.7.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A simple immutable mapping for python"
-HOMEPAGE="
- https://github.com/Marco-Sulla/python-frozendict/
- https://pypi.org/project/frozendict/
-"
-SRC_URI="
- https://github.com/Marco-Sulla/python-frozendict/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/python-${P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64"
-
-distutils_enable_tests pytest
-
-python_compile() {
- # This prevents the build system from ignoring build failures, sigh.
- local -x CIBUILDWHEEL=1
-
- distutils-r1_python_compile
-}
-
-python_test() {
- rm -rf frozendict || die
- epytest
-}