summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-23 09:02:13 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-23 09:58:44 +0100
commit24db097a0552183e81d2969586d6d503b02d0fd7 (patch)
tree72f237ae867c8935c784e68bdbcc113a8cc1f80d /dev-python
parentdev-python/fonttools: Bump to 4.31.2 (diff)
downloadgentoo-24db097a0552183e81d2969586d6d503b02d0fd7.tar.gz
gentoo-24db097a0552183e81d2969586d6d503b02d0fd7.tar.bz2
gentoo-24db097a0552183e81d2969586d6d503b02d0fd7.zip
dev-python/rich: Bump to 12.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-12.0.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 242056873273..86b25f2ab64b 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,2 +1,3 @@
DIST rich-11.2.0.gh.tar.gz 16300346 BLAKE2B 520f512a7e26613a4cc881834f8c150963b84a6dc3a43029dde6d64d1e405d82422b9c6f0098293b6f9bdb55749c7929426dad14840c9a287889c1a6a70f6bf2 SHA512 ec1178a6a320a48f589ead5163e974725f79ae63ddf9a2deb66400e43619ade8d366dbef6b524e66e603647a957b8e26266845a0bcb85912fd9ad2a81dd92f5e
DIST rich-12.0.0.gh.tar.gz 14727980 BLAKE2B b9f7761ab1084765f804fd22f9fb18e659f91b917bb452217752683f6d61320d2703eee28de3be3bd70009fc06d04165528393c4c0ec32a49b1dc7e94989a224 SHA512 4e47e48709180ef844bcf1cd516b22de8a4f22c5121ca0582a2cff7297d97afe63232926d518cd2bf4d6d1a7cea362ab12e71eedacce6b6d378ef1a1528d9e4c
+DIST rich-12.0.1.gh.tar.gz 14857207 BLAKE2B 8e6419904ef0ba91d4b15059630f63769a28323600cb212f07c2a239201489e2078b8c4c792f486bde75efd9d09afe832fa2e2235ac91433ee24b33fcda02e68 SHA512 61077663b46a7e615b29df3b75b15ef97979c804abd283cc26f217ee8128b74a514fd7b92831d1d8928f768d2ec8230d8cd1da733106b424704a3187ee18ce95
diff --git a/dev-python/rich/rich-12.0.1.ebuild b/dev-python/rich/rich-12.0.1.ebuild
new file mode 100644
index 000000000000..e156699e5e9c
--- /dev/null
+++ b/dev-python/rich/rich-12.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/Textualize/rich"
+SRC_URI="
+ https://github.com/Textualize/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # check for exact color render string, which changes across pygments bumps
+ tests/test_syntax.py::test_python_render
+ tests/test_syntax.py::test_python_render_simple
+ tests/test_syntax.py::test_python_render_indent_guides
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}