summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-04-19 14:17:49 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-04-19 14:22:02 +0300
commit26fd4524314638aa77126ed90e931485278023e2 (patch)
tree79e27dbf0f835df4d7333a17df304382ea96b9b1 /dev-python
parentdev-libs/libpcre2: arm64 stable (bug #717800) (diff)
downloadgentoo-26fd4524314638aa77126ed90e931485278023e2.tar.gz
gentoo-26fd4524314638aa77126ed90e931485278023e2.tar.bz2
gentoo-26fd4524314638aa77126ed90e931485278023e2.zip
dev-python/roman: bump to 3.2
- non-maintainer commit. - EAPI-7, - PYTHON_COMPAT 3.7, 3.8. - tests pass, * python3_6: running distutils-r1_run_phase python_test Ran 4 tests in 0.000s * python3_7: running distutils-r1_run_phase python_test Ran 4 tests in 0.000s * python3_8: running distutils-r1_run_phase python_test Ran 4 tests in 0.000s Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/roman/Manifest1
-rw-r--r--dev-python/roman/roman-3.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/roman/Manifest b/dev-python/roman/Manifest
index 91e3c65cdc94..765fd32a41f7 100644
--- a/dev-python/roman/Manifest
+++ b/dev-python/roman/Manifest
@@ -1 +1,2 @@
DIST roman-3.0.tar.gz 5184 BLAKE2B 0951e15a1fbf0feecc98c4318fa631a535d24d9559d21e800f065923c71d094c387b18c5926ad55322ad8417a2db97626ada1e110549938d73243ca410e3ab87 SHA512 468a4ac7188cdf3155698f260de5ecc5bb2072c120c79d046618ac07b6de6f777cfc69661f2e0df4ca66359bb20169d22599b3f342edaa48f8575bdc17b40c08
+DIST roman-3.2.tar.gz 7156 BLAKE2B ba7233366ab9bea9f0de4ab02ddbff4a3fbcc35792165d59f291dc837f4a8a7e681f1be89bcbb9746beb88fd7ae57b4ab57934e8d72a73bbdf223840e37cc18e SHA512 142904551745c8b7874d52c8d04f483b0c18b18ba8bc3d3a51fcf509e09b3a3f8a28d0b88bdd8282957bf3d698b1bab86de7fb4808cde9b0e5cfb910deca35ab
diff --git a/dev-python/roman/roman-3.2.ebuild b/dev-python/roman/roman-3.2.ebuild
new file mode 100644
index 000000000000..3627189d1ffb
--- /dev/null
+++ b/dev-python/roman/roman-3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="An Integer to Roman numerals converter"
+HOMEPAGE="https://pypi.org/project/roman/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !<dev-python/docutils-0.9[${PYTHON_USEDEP}]"
+
+python_test() {
+ cp "${S}/src/tests.py" . || die "copying test file failed"
+ esetup.py test
+}