summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-18 16:26:13 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-18 16:59:34 -0500
commit29071277a79cd3458517f4057359c1409ae483a3 (patch)
treeff61a00b86ef3408669a674206666fdd95dcbd73 /dev-python
parentdev-python/os-vif: 2.2.0 bump (diff)
downloadgentoo-29071277a79cd3458517f4057359c1409ae483a3.tar.gz
gentoo-29071277a79cd3458517f4057359c1409ae483a3.tar.bz2
gentoo-29071277a79cd3458517f4057359c1409ae483a3.zip
dev-python/os-xenapi: 0.3.4-r1 add py38
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/os-xenapi/os-xenapi-0.3.4-r1.ebuild29
-rw-r--r--dev-python/os-xenapi/os-xenapi-0.3.4.ebuild15
2 files changed, 33 insertions, 11 deletions
diff --git a/dev-python/os-xenapi/os-xenapi-0.3.4-r1.ebuild b/dev-python/os-xenapi/os-xenapi-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..ebbae8bcf51d
--- /dev/null
+++ b/dev-python/os-xenapi/os-xenapi-0.3.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="XenAPI library for OpenStack projects"
+HOMEPAGE="https://github.com/openstack/os-xenapi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/os-xenapi/os-xenapi-0.3.4.ebuild b/dev-python/os-xenapi/os-xenapi-0.3.4.ebuild
index c98114f7dade..e6a46c5076e0 100644
--- a/dev-python/os-xenapi/os-xenapi-0.3.4.ebuild
+++ b/dev-python/os-xenapi/os-xenapi-0.3.4.ebuild
@@ -15,12 +15,9 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
IUSE=""
-CDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
+DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
RDEPEND="
- ${CDEPEND}
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
>=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
>=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
!~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
@@ -28,9 +25,5 @@ RDEPEND="
>=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"