summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2017-03-18 19:29:08 +0100
committerDavide Pesavento <pesa@gentoo.org>2017-03-18 19:29:59 +0100
commit29ea6e4a707bd619c5dac4b6002a43a15c78ef13 (patch)
tree1956e9e817d333f3f86ec2dbe13cd5a37cdac236 /dev-python
parentkde-misc/basket: Drop old (diff)
downloadgentoo-29ea6e4a707bd619c5dac4b6002a43a15c78ef13.tar.gz
gentoo-29ea6e4a707bd619c5dac4b6002a43a15c78ef13.tar.bz2
gentoo-29ea6e4a707bd619c5dac4b6002a43a15c78ef13.zip
dev-python/sip: remove old
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/sip-4.18.1.ebuild87
2 files changed, 0 insertions, 88 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 0de040f79c50..38bedb0e0518 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,3 +1,2 @@
-DIST sip-4.18.1.tar.gz 992624 SHA256 9bce7a2dbf7f105bf68ad1bab58eebc0ce33087ec40396da756463f086ffa290 SHA512 c4277fa113bf5e28d8a19388f160456654e4ccbbc2adc1209677e95e1efad427ce641ef09875ec0a59e555578986671261dd4c3ac52c673b5803f188fc311222 WHIRLPOOL 6250081ffda585dda7c7728fe1253a1791ef63d4798d02c752e1c5b58837d2c55dd87306c83202be03f96bd644bd5b17b3b1e28b5c06b28bb8a69dd23da2ee09
DIST sip-4.18.tar.gz 991980 SHA256 f1dc5c81c07a9ad97edcd4a0af964a41e420024ba7ca165afd2b351efd249cb6 SHA512 365fb51b8c833ebc923b87a961fac83976b653ebcec8fe7ad1543ee5a406471eb9309c8efbee6662c7b622f36771cd3ac31ede10208f23d2531a45af906d383d WHIRLPOOL 3cf3516483e62ed26fca1de6bc90e58a2bd04d3d66214b0f62eb4338c2b7a8a595d46952ef86cd7fa61e50b160a06b484a7d4f5997be2f2a7714b1edabaef2a4
DIST sip-4.19.1.tar.gz 1000644 SHA256 501852b8325349031b769d1c03d6eab04f7b9b97f790ec79f3d3d04bf065d83e SHA512 fd98002117e9526f7f981b46362c41171e703a0e18e57112fcabf33d71fa13a4a091fdcb05c879ea721da59fa8c03087b8dc983fb2f832f764e5ad950c9bbecf WHIRLPOOL 87deee5786ca5009ca139bf6993e82231b1dd5be9bf7ee1d94eb5c8aabf5bda980f6b0fa4571e838275ac7cd8615757a58d0b9d7e776705834db35a1dc92125d
diff --git a/dev-python/sip/sip-4.18.1.ebuild b/dev-python/sip/sip-4.18.1.ebuild
deleted file mode 100644
index 6eb2996f66d0..000000000000
--- a/dev-python/sip/sip-4.18.1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit python-r1 toolchain-funcs
-
-DESCRIPTION="Python extension module generator for C and C++ libraries"
-HOMEPAGE="https://www.riverbankcomputing.com/software/sip/intro"
-SRC_URI="mirror://sourceforge/pyqt/${P}.tar.gz"
-
-# Sub-slot based on SIP_API_MAJOR_NR from siplib/sip.h.in
-SLOT="0/11"
-LICENSE="|| ( GPL-2 GPL-3 SIP )"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="debug doc"
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-4.18-darwin.patch )
-
-src_prepare() {
- # Sub-slot sanity check
- local sub_slot=${SLOT#*/}
- local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h.in)
- if [[ ${sub_slot} != ${sip_api_major_nr} ]]; then
- eerror
- eerror "Ebuild sub-slot (${sub_slot}) does not match SIP_API_MAJOR_NR (${sip_api_major_nr})"
- eerror "Please update SLOT variable as follows:"
- eerror " SLOT=\"${SLOT%%/*}/${sip_api_major_nr}\""
- eerror
- die "sub-slot sanity check failed"
- fi
-
- default
-}
-
-src_configure() {
- configuration() {
- local myconf=(
- "${PYTHON}"
- "${S}"/configure.py
- --bindir="${EPREFIX}/usr/bin"
- --destdir="$(python_get_sitedir)"
- --incdir="$(python_get_includedir)"
- $(usex debug --debug '')
- AR="$(tc-getAR) cqs"
- CC="$(tc-getCC)"
- CFLAGS="${CFLAGS}"
- CFLAGS_RELEASE=
- CXX="$(tc-getCXX)"
- CXXFLAGS="${CXXFLAGS}"
- CXXFLAGS_RELEASE=
- LINK="$(tc-getCXX)"
- LINK_SHLIB="$(tc-getCXX)"
- LFLAGS="${LDFLAGS}"
- LFLAGS_RELEASE=
- RANLIB=
- STRIP=
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- emake DESTDIR="${D}" install
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- einstalldocs
- use doc && dodoc -r doc/html
-}