summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-02-13 12:33:41 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-02-13 12:33:41 +0700
commit2a3b517d58aebc763b195e65918a4a456f685107 (patch)
tree4813d4f15ebc3690931be63412a33993d45b3b00 /dev-python
parentmedia-plugins/kodi-inputstream-adaptive: 2.0.19 version bump (diff)
downloadgentoo-2a3b517d58aebc763b195e65918a4a456f685107.tar.gz
gentoo-2a3b517d58aebc763b195e65918a4a456f685107.tar.bz2
gentoo-2a3b517d58aebc763b195e65918a4a456f685107.zip
dev-python/bpython: bump to 0.17.1
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/bpython/Manifest1
-rw-r--r--dev-python/bpython/bpython-0.17.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/bpython/Manifest b/dev-python/bpython/Manifest
index e6e6a98e616b..55bb645faa62 100644
--- a/dev-python/bpython/Manifest
+++ b/dev-python/bpython/Manifest
@@ -1,2 +1,3 @@
DIST bpython-0.16.tar.gz 201898 BLAKE2B 907f6a506d2b52db01e7b84c615574a7daad36f630646a345c963e432cc394330339390b6afc2585845b19d6c00d9c0b95e06b9d3b0fe85fe20daad3f5cf208a SHA512 1173d720aa679e4a6079c7febd36abbffa901604c99c6d1ce1e940a8fbcf8a4ba7bc526de0ef5290e3859a4384d1cd5cbef62fd9f056ddcb545b64d69d103a5b
+DIST bpython-0.17.1.tar.gz 213638 BLAKE2B 42530a38f8cf714a0415957a46374b83ad14dfab89a76317507763c2f83b3dbc8f71c7cc967ec353fabd38b6631130d34df99c0d53f3728fa2390d4a6f64b25d SHA512 5b5e861646df90510db75520dff9533b71501d35b7af1d152adf2c929b171fa6a2b1c0a6b7eda0311f9315703db161c6a78698a6cd434e5321464d6d1c033e4e
DIST bpython-0.17.tar.gz 214230 BLAKE2B dc26de037eb5698c04afb74472fe9483e1398f4f40b7da21520f2e7e2ba6e510bcbf200938d520d95b976a6fbeb31af7b1b1f828a022835edbe40d381c82797d SHA512 17c25f4ed69eb7cff27ba0a488434623a7105c60bbf1e6f608c91babf240741ab7a7097ad347f897cd5f39f2fedb944fd69d8dbfbc66da6b910e1a14ace6fd1f
diff --git a/dev-python/bpython/bpython-0.17.1.ebuild b/dev-python/bpython/bpython-0.17.1.ebuild
new file mode 100644
index 000000000000..6905eb544957
--- /dev/null
+++ b/dev-python/bpython/bpython-0.17.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="http://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.python.org/pypi/bpython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/curtsies-0.2.11[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/jedi[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+DOCS=( AUTHORS CHANGELOG sample.theme light.theme )
+
+# Req'd for clean build by each impl
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build -b html -c doc/sphinx/source/ \
+ doc/sphinx/source/ doc/sphinx/source/html || die "docs build failed"
+ fi
+}
+
+python_test() {
+ pushd build/lib > /dev/null
+ "${PYTHON}" -m unittest discover || die
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/sphinx/source/html/. )
+ distutils-r1_python_install_all
+}