summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-08-28 02:11:34 -0400
committerTim Harder <radhermit@gentoo.org>2015-08-28 02:12:44 -0400
commit2cea8c9338957ea07089af0a6803244efcba03ff (patch)
tree4fd15ac6df47501d9f9a5576913501da12fd9d59 /dev-python
parentapp-misc/pax-utils: version bump to 1.1.1 (diff)
downloadgentoo-2cea8c9338957ea07089af0a6803244efcba03ff.tar.gz
gentoo-2cea8c9338957ea07089af0a6803244efcba03ff.tar.bz2
gentoo-2cea8c9338957ea07089af0a6803244efcba03ff.zip
dev-python/apsw: version bump
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.8.11.1_p1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index 97287626df02..35499ddf87c9 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1,2 +1,3 @@
DIST apsw-3.8.10.1_p1.tar.gz 307142 SHA256 af20221e1a65f593b47d83f1f8a136afc6d2199a22bc014251a44e31e7b0ca17 SHA512 1f997c6c88ca65995c8b5d894135d5900a4d2f56f877f74f0e99eab4ede0d06be5730ce282a5d99358318ca076eec75f2afe271574b6c02aaabf4bef181d0bda WHIRLPOOL 3e9b609a19ee39edda9af8140982c74d53d3e2b4c0bd05ea53974cb7a3c2f12f13ab4acf1d51ac5b50ee738f5380dc83b819e0ed11bf28107f903f0a52eb5949
+DIST apsw-3.8.11.1_p1.tar.gz 307797 SHA256 f4dc653aca10dfae8578c8bf1125600f77d0d8dcc85b4185754388aa87ae0997 SHA512 4ca857d32f423475b17e81130d4919627d581b80dd6f3f120d95906ddad657d6f52eb69fb211612e15f5eaee0211c0ad992391c93068a463e72670d49f69c61e WHIRLPOOL 15a58a83e1e5f3ee4afc470a0d58e29f5ee5cf416897b1c83ad021fb9c47f0533a5e01417aa59fb74e7b33ad9e5f1a74b40c0cbffcee4cf01617006dbad3dc2a
DIST apsw-3.8.7.1_p1.tar.gz 303446 SHA256 7aee29cc170332aa1a16fb80753152e809208bbc91823f64178e4afc32526fec SHA512 104aad3a8cec07647b71c77814cc069587daf84450b41f992d0b3c752c476105351b28912768a29f7952bfd75e9b2d3fcd8e6ae758b3bab8b986bf8e1300c256 WHIRLPOOL cc95728b07e384ee88002afce4b68abcfb259a62188cc77bad1154a83bf3e1979fec8761fe8a3c9e5ae35d5027cdf42c1b4a4b7749ad76d7935e032e253c8167
diff --git a/dev-python/apsw/apsw-3.8.11.1_p1.ebuild b/dev-python/apsw/apsw-3.8.11.1_p1.ebuild
new file mode 100644
index 000000000000..a61ba236392c
--- /dev/null
+++ b/dev-python/apsw/apsw-3.8.11.1_p1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_p/-r}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="https://code.google.com/p/apsw/"
+HOMEPAGE="https://github.com/rogerbinns/apsw/"
+SRC_URI="https://github.com/rogerbinns/apsw/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-db/sqlite-${PV%_p*}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-3.6.20.1-fix_tests.patch )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ fi
+ distutils-r1_python_compile --enable=load_extension
+}
+
+src_test() {
+ # tests use overlapping database files
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ distutils-r1_src_test
+}
+
+python_test() {
+ "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
+ "${PYTHON}" tests.py -v || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use doc ; then
+ dohtml -r doc/*
+ fi
+}