summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-03-01 10:54:56 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-03-01 10:54:56 +0700
commit2ed98a4a3ff0c50a330271f2efebd4fc188ba12c (patch)
treeb1478213d9be72fc5da8b3405ea0ab2e80b4e93d /dev-python
parentdev-python/backcall: add python3_8 (diff)
downloadgentoo-2ed98a4a3ff0c50a330271f2efebd4fc188ba12c.tar.gz
gentoo-2ed98a4a3ff0c50a330271f2efebd4fc188ba12c.tar.bz2
gentoo-2ed98a4a3ff0c50a330271f2efebd4fc188ba12c.zip
dev-python/prompt_toolkit: bump to 3.0.3, add python3_8 to 2.0.10-r1
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/prompt_toolkit/Manifest1
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-2.0.10-r1.ebuild22
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.3.ebuild22
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index 606c710da9f9..6a8b5e48869d 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -2,3 +2,4 @@ DIST prompt_toolkit-1.0.15.tar.gz 243734 BLAKE2B b27e61bb444360abe95714e2014fcac
DIST prompt_toolkit-2.0.10.tar.gz 347981 BLAKE2B b95cf000d5249da3710f9b51f72d41c3d552f1d3a35dea5493f565f0f62998d890bf2b81b3376140a4d16a19f2c5fd60eb0cb5f2f58180c176ef1543c6fc4ec2 SHA512 b91292cf43607b3a7018ca29827f0aa9bc90efc064c68faffe02ad28e4bb60f45fc2d25bbfd9a40a383a815cb08596975f08237a498f94a5c088d56d3a0a9803
DIST prompt_toolkit-2.0.6.tar.gz 339714 BLAKE2B f969edef98d25930e4d61c1500bb9c8d731dea29e8d154e6baa2ab4045ceaf9d577d46024734a255cc15a4c13685582309e9d2fe7ae3320257f6fd1f9981ada6 SHA512 37082011ee5b8d6fd9febef95c92494ed6108b9ad8c64ac580b69c3464781a2f0dcef5b1c4d06fe309a3036932f7c622042e6b2293acf2ab6f9f2aa3c48d9322
DIST prompt_toolkit-2.0.7.tar.gz 343267 BLAKE2B eed36fb951bcf8b0663a87eb4e77267246bbc7a6b773ed76d730c04b4dd012434fd0e71e5f558c231fd5ba1e8b3403878106bf3c60f44b7aa3e492a99a622b65 SHA512 4ea8102a50290878248ccc2119eb2b5ae50ad58f466510f8328bc172942f5417abde24393958c910ae0ab2ea4a8caff049b6e7acd8d94e9dbeb97b36c6e2191e
+DIST prompt_toolkit-3.0.3.tar.gz 2997855 BLAKE2B e4fe0d6b43443fd541a5cd2a38c6bb503cd86a6d222e2d0ea692496ca9591ee7ea2147618a224ee4e86d69e74c8bf95c7c408d592e94895d5d6d985e721f26e6 SHA512 4fde083359445c6195c4f15d69e380a3454147e41aaa022cb237734896be191102de92509c011b39d6b31304b6443e8ba0092874fb90db911081f90e9e53b66a
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-2.0.10-r1.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-2.0.10-r1.ebuild
new file mode 100644
index 000000000000..12a2ac5b83b7
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-2.0.10-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="https://pypi.org/project/prompt_toolkit/ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.3.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.3.ebuild
new file mode 100644
index 000000000000..12a2ac5b83b7
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="https://pypi.org/project/prompt_toolkit/ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest