summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Vig <sean.v.775@gmail.com>2015-08-22 18:12:57 -0500
committerSean Vig <sean.v.775@gmail.com>2015-08-22 21:41:58 -0500
commit3a51d23efaa263cb0198c04b01b1a25a4ff72808 (patch)
tree80de99ea04b50261118592be63e3f37a888d9c4d /dev-python
parentdev-python/cairocffi: Don't enable pypy Python target on dev-python/cffi (diff)
downloadgentoo-3a51d23efaa263cb0198c04b01b1a25a4ff72808.tar.gz
gentoo-3a51d23efaa263cb0198c04b01b1a25a4ff72808.tar.bz2
gentoo-3a51d23efaa263cb0198c04b01b1a25a4ff72808.zip
dev-python/cryptography: Enable pypy as Python target
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cryptography/cryptography-1.0.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/cryptography/cryptography-1.0.ebuild b/dev-python/cryptography/cryptography-1.0.ebuild
index c06bcfde5b5a..89753712433b 100644
--- a/dev-python/cryptography/cryptography-1.0.ebuild
+++ b/dev-python/cryptography/cryptography-1.0.ebuild
@@ -5,7 +5,7 @@
EAPI=5
# only works with >=pypy-2.6
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
inherit distutils-r1
@@ -27,6 +27,7 @@ RDEPEND="
>=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]