summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-09 23:38:28 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-10 02:05:05 +0000
commit3e9b88fc840f3fcb842f37080a86132c7e853d5d (patch)
tree73be876d47aac6d4ff2959df989594aab596c6c0 /dev-python
parentdev-python/spectral-cube: initial import (diff)
downloadgentoo-3e9b88fc840f3fcb842f37080a86132c7e853d5d.tar.gz
gentoo-3e9b88fc840f3fcb842f37080a86132c7e853d5d.tar.bz2
gentoo-3e9b88fc840f3fcb842f37080a86132c7e853d5d.zip
dev-python/rootpy: version bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rootpy/Manifest1
-rw-r--r--dev-python/rootpy/rootpy-0.8.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/rootpy/Manifest b/dev-python/rootpy/Manifest
index 099aa4632957..6e44ef459191 100644
--- a/dev-python/rootpy/Manifest
+++ b/dev-python/rootpy/Manifest
@@ -1,2 +1,3 @@
DIST rootpy-0.7.1.tar.gz 305412 SHA256 d36399125ed8540b9a651e7b5c7ddeba686ef3107830d3d6d840cdae4834751c SHA512 460e5d79da08c141c762a5a92cf50694fe1fee8677a2439b5525b67e7d6a1a6af18a4e6dc91d379b394a97dc973da8f6baa534d46e506e0a7a4d0ee632de1a2a WHIRLPOOL d9663274a36c490bb4c872be83527d3dd414d9cca989cf20a2aca1ac5441532c9b29571d0ff885458fd2e820dc7905a679e1c9873305848ccd1fafa7820a84be
DIST rootpy-0.8.0.tar.gz 415826 SHA256 ec0fc969101b6208e722bb9ae11dfe4a02ea53f8f91f591a5c2ea46f26581948 SHA512 0b9dc9c5bee263a2eb33b464bd96f4f9d0820a03722ca2fe3ccfaf11786caf7ccd6d25ffe4ffd42c4a5481bd3b33576cfbf68c01f2af7a981f6a2c1bedc514e2 WHIRLPOOL 7036db8d78c543259801557ebfd940cec7a3083c21757374cf5464a420643cd95cbadc898fe644181cbaa072587a0e49bd56f74f76a8670636604a32da14ddb4
+DIST rootpy-0.8.3.tar.gz 417400 SHA256 1fac940e1a22f37573db8b83040cf5517464e48c1ef5700a4a651425345c0993 SHA512 b1d3c17fb0a6dfe36bdf3d9a345fc55af8a102d33433c951581f9a61babf377fabb1ae486c78b2d4654cbc7320de122fb3075f27a1565655a3dc17c2b4f56df6 WHIRLPOOL a2f37284270c501715139117071a582c250290d7681bf1274862e364b472a0c04df56ec6d61b9ffcc7f1f0ce5ac8d0bd74f83a5607a929f8fe7de60d572010ea
diff --git a/dev-python/rootpy/rootpy-0.8.3.ebuild b/dev-python/rootpy/rootpy-0.8.3.ebuild
new file mode 100644
index 000000000000..29e6271da6e8
--- /dev/null
+++ b/dev-python/rootpy/rootpy-0.8.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="readline"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic layer on top of the ROOT framework's PyROOT bindings"
+HOMEPAGE="http://rootpy.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ sci-physics/root[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/root_numpy[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]"
+
+DEPEND="
+ sci-physics/root[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# TOFIX: tests go in an infinite loop error
+RESTRICT=test
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}