summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-23 21:54:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-23 22:12:27 +0200
commit3fc86d38da722e0a475ee47953f42bac4a2ebc06 (patch)
treedbf9167f0b34141f927fe3bc5ab0bf20f529caae /dev-python
parentdev-python/django-otp: Bump to 1.0.2 (diff)
downloadgentoo-3fc86d38da722e0a475ee47953f42bac4a2ebc06.tar.gz
gentoo-3fc86d38da722e0a475ee47953f42bac4a2ebc06.tar.bz2
gentoo-3fc86d38da722e0a475ee47953f42bac4a2ebc06.zip
dev-python/GitPython: Bump to 3.1.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/GitPython/GitPython-3.1.11.ebuild58
-rw-r--r--dev-python/GitPython/Manifest2
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.11.ebuild b/dev-python/GitPython/GitPython-3.1.11.ebuild
new file mode 100644
index 000000000000..2dedec128a2b
--- /dev/null
+++ b/dev-python/GitPython/GitPython-3.1.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+TEST_P=GitPython-${PV}
+GITDB_P=gitdb-4.0.5
+SMMAP_P=smmap-3.0.4
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
+ )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+
+ git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
+ git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb || die
+ git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
+
+ cd "${T}"/test || die
+ rm -r test/performance || die
+ # tests requiring network access
+ sed -i -e 's:test_fetch_error:_&:' test/test_remote.py || die
+ rm test/test_installation.py || die
+ # broken apparently (also fails in git clone)
+ sed -e 's:test_rev_parse:_&:' \
+ -i test/test_repo.py || die
+
+ distutils-r1_src_test
+}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index a623417a426a..ec87dcc2317c 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,3 +1,5 @@
+DIST GitPython-3.1.11.gitbundle 4421698 BLAKE2B 96a4be2b12149c34f0e81580cb8906920a107f9856da585779f8d13590fb14c838a5e73d8831692ea81dd0ed73e17cdab1020b50cb49c7f193d54c1e838d9385 SHA512 64a443e0c517627045d98f7a60b6cdd817f6af3d12f5619cca7c4e24f9ce42018c2aca427365d633e4aaeb5e99d99a944d85b2286c34be1c17e85e441d9693c3
+DIST GitPython-3.1.11.tar.gz 170908 BLAKE2B b327f38bbe9d92caf8b5ba6f3c1e353ad00bad2c3e7b3ae59991eaee5a5dd9f228fd80b86fd7e908fa71563e369d7340070ddc0e093549bfc8378cdf20ba9723 SHA512 fe4baf9c8b3668f29fbc476ec2ba0a8d58a50ffe596b9f3037ddb4cb5c0c7faf0d34c6efac7567074f1b28b866e42dad19c91a5381eef606d3b3ff74b77649de
DIST GitPython-3.1.8.gitbundle 4418113 BLAKE2B b6c2154b8f1eadc005055c8c04a9c2ee5e9b365bcbb258cf24d676aa5e1d7f598c26c5404606f8c48d2e2165615e6cf4b3006f071cc3a3bb2047990d232f16d2 SHA512 d506bc72ae10227fde57c8497ad41a2da9e9b4613b3b98ca6a0d48cf8286bdc3e9d71284a5fededd2df075042a12dd8074e07c32defda707865c129dc83b7247
DIST GitPython-3.1.8.tar.gz 170582 BLAKE2B 0ca3111ce09259b9b071d43b06715b187a6f428dd81002c57215c60e720447007220536f51d681c5468ebe91a4144769b57f6a8c80d29683c26f0f07d984d765 SHA512 8848b58738d7dd33b8c3186d9db0eb41a6e428050f4fe170351e42c941c9586ba4999bf5083fbbe2b7ce73a668a0f62cfb19be013f470c7b8f0733d07d9bee32
DIST gitdb-4.0.5.gitbundle 1497722 BLAKE2B 8ee85368db7f408f96f0b48250f1ed96c8df28b0439d355ce2eecbdcc5dc94382883510c57142e7e4b6ba7cd8e82b1140eca538b45692dbe8c55bce32e1b5b4f SHA512 2c55a8e402a61ebcc362a8aee4a6154705d8ff2f5e582d13c855562dd074427681f4147641fe76681b76c99ec46040c7577dfca8bbfd575fc52772a9a6f17326