summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-13 06:39:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-13 06:46:26 +0200
commit40021577c6ea1025396a78053b6ed2571c678681 (patch)
tree910fd28b60dc83fc43079dd24bc5cd28e0c714a3 /dev-python
parentdev-python/jsonschema-spec: add dev-python/responses test dep (diff)
downloadgentoo-40021577c6ea1025396a78053b6ed2571c678681.tar.gz
gentoo-40021577c6ea1025396a78053b6ed2571c678681.tar.bz2
gentoo-40021577c6ea1025396a78053b6ed2571c678681.zip
dev-python/filelock: Bump to 3.12.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/filelock/Manifest1
-rw-r--r--dev-python/filelock/filelock-3.12.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/filelock/Manifest b/dev-python/filelock/Manifest
index 4d5dba791631..02f9ec031a5e 100644
--- a/dev-python/filelock/Manifest
+++ b/dev-python/filelock/Manifest
@@ -1,2 +1,3 @@
DIST filelock-3.12.0.tar.gz 11839 BLAKE2B 3c363e7e7ca39ddf21a6c86ed4e98eff170c3be6d4c8429a641403dd7d90058a6f15330457f01217b994959514ad297aa5ae8807b0f1d6359455cf5776be8b90 SHA512 4bd5d9df76499e2a4f9dd9274fcc8bd507813446fa8e5852cef6c674d34d3db2313e4b79ac98eae07d6a9fe953de4ee6390baa4c9d5ab6a005c96324dd5904e8
DIST filelock-3.12.1.tar.gz 12445 BLAKE2B 7f4a115e6b50976935fee917ca7ebcba13129ad1494f8f536502c4f34335aee1f83a18393b01707195b362f83246d6ba86bd26859846540fb6de12c416f6a43c SHA512 c08768d230cad4407f21b23578a009da61858f347d3ca189756b1da32b61b70c187029786f00e286f76f026b561beb270e87b19fc1caf3fdeaea5eb96c208ae8
+DIST filelock-3.12.2.tar.gz 12441 BLAKE2B a54eb7841bd037caf537144829818ab25acf7b5a916c6fc2a296a937f36a36b7846cce3b35e751041ccc1dfc5c5c4be1b6031a261927c152657f968bb465915b SHA512 0753743338c4937f57176ef2291f44a919d949c7b3aa73e3210572d670949a60a9ad3efaaaeff198704e1308c169807655bb90d399c1158e4f5c9aae4adcd486
diff --git a/dev-python/filelock/filelock-3.12.2.ebuild b/dev-python/filelock/filelock-3.12.2.ebuild
new file mode 100644
index 000000000000..5395bafa0b35
--- /dev/null
+++ b/dev-python/filelock/filelock-3.12.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="
+ https://github.com/tox-dev/py-filelock/
+ https://pypi.org/project/filelock/
+"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest