summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-12 21:00:16 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-12 21:01:24 +0100
commit40401ae2e5dbb413e1aec9f8f8ab54436b738c24 (patch)
tree16327cade87bed4b4ea8d2df9966e1170a659c27 /dev-python
parentpackage.mask: Mask sys-libs/efivar-0.22 (diff)
downloadgentoo-40401ae2e5dbb413e1aec9f8f8ab54436b738c24.tar.gz
gentoo-40401ae2e5dbb413e1aec9f8f8ab54436b738c24.tar.bz2
gentoo-40401ae2e5dbb413e1aec9f8f8ab54436b738c24.zip
dev-python/setuptools: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-20.1.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 106fa6bc7f85..fe9bae1d25e9 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -13,3 +13,4 @@ DIST setuptools-19.6.2.tar.gz 641373 SHA256 69261eefdb21057cfbe92ba8032b923d6363
DIST setuptools-19.6.tar.gz 641502 SHA256 ecd48d753c1a8ecc6a2826b863a6defaafbfd4ceafc0c1d62e5362f5a86912e9 SHA512 79b9a0f595bda16f18997d9937c6bc2e21bb2bb23fcca4be29df2fb71649c5ba973428472e3c795f2a5d6fbcccf1d5f29096a0fb593a4c52fa87b1d003e474da WHIRLPOOL 391f3e20739c717cc42613e099b867ee01cd8a1f3623f31062dee23131c3b1bad2e34345348f76e44ff2b92652cf65931b3fd8b6a7663b9c135a7c03b6954405
DIST setuptools-19.7.tar.gz 641634 SHA256 9e0783f3e6b736530a84980dce99fb0f01dafcd31b3f600cde2aa446f6f77cc0 SHA512 fe74b10eb1afef5d78cc5cd4d6dbd53ed16f975c693c138181dfb1661276255d214037eb036186d0cdc9dd31d636f9f1067d67bf591542e8ef933afca267ee4c WHIRLPOOL e1ee325d3de9a6b0dfd49fc68129271faeaccf5ffb77a750f553986fc47b75a5003c17a3f00d76be15eb3808d04e7060f5ccddb9ca9c804fbb68ad54c01453f4
DIST setuptools-20.0.tar.gz 641692 SHA256 a6f7b295f399fed3de918c4bea9e2053a5fbd9e3a55a6fef7aafe9d1f474866d SHA512 c77b8f963c1c2735014f344cb3fba6ab88fc034ea32e52501a19430538db4bc6217706532ac3427f928d55b9a2321a0948f57aca5c7a01020868efc9231dd174 WHIRLPOOL 2d2a1bb7c5ea4ace4da1ddceb6f03605858be10f8c835f8aee9be896041c3c84680f6f09edc4cbcefc99a209d6b3a9ca50f2413a8e226861ceee135543e409d3
+DIST setuptools-20.1.1.tar.gz 641777 SHA256 2663ce0b0e742ee27c3a06b2da14563e4f6f713eaf5509b932a31793f9dea9a3 SHA512 72da2f5a4e07c14975b3e13246264cb4b9eb52bd6da22fce0ef0f0bb8d902249067e6c23bf263cda45de92a0cdb794f454dff95e52505045e03c7a6ab28cb2ca WHIRLPOOL d2f3f0fd31f4b7d35178c14cd411dae0b011c3f9efd8a7dea4cde24bee1e462758a9662e989ddea7777b111c6162e7d035cf924517e7e6bdcab0b3277d7765e1
diff --git a/dev-python/setuptools/setuptools-20.1.1.ebuild b/dev-python/setuptools/setuptools-20.1.1.ebuild
new file mode 100644
index 000000000000..300425331f6d
--- /dev/null
+++ b/dev-python/setuptools/setuptools-20.1.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://pypi.python.org/pypi/setuptools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/packaging-15.3-r1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND=">=dev-python/certifi-2015.11.20[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ rm -r ./pkg_resources/_vendor || die
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}