summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-02 06:21:32 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-02 06:42:35 +0100
commit44ca5be66923dc2bb1a93b80f7e918ad2df4879a (patch)
tree9a09afbd53917d370b7d66e27dfd20d5fe8046ec /dev-python
parentdev-python/cached-property: Steal for python@ (diff)
downloadgentoo-44ca5be66923dc2bb1a93b80f7e918ad2df4879a.tar.gz
gentoo-44ca5be66923dc2bb1a93b80f7e918ad2df4879a.tar.bz2
gentoo-44ca5be66923dc2bb1a93b80f7e918ad2df4879a.zip
dev-python/cached-property: Remove test compat with removed impls
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cached-property/cached-property-1.5.1.ebuild24
1 files changed, 6 insertions, 18 deletions
diff --git a/dev-python/cached-property/cached-property-1.5.1.ebuild b/dev-python/cached-property/cached-property-1.5.1.ebuild
index 879fa766f1b0..88b62f7a15e8 100644
--- a/dev-python/cached-property/cached-property-1.5.1.ebuild
+++ b/dev-python/cached-property/cached-property-1.5.1.ebuild
@@ -13,28 +13,16 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-DEPEND="test? (
- dev-python/pytest
- dev-python/freezegun
- )"
+DEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )"
RDEPEND=""
+distutils_enable_tests pytest
+
src_install() {
distutils-r1_src_install
dodoc README.rst HISTORY.rst CONTRIBUTING.rst AUTHORS.rst
}
-
-python_test() {
- local ignore=""
- if [[ ${EPYTHON} == python2.7 ]]; then
- ignore="--ignore=tests/test_coroutine_cached_property.py \
- --ignore=tests/test_async_cached_property.py"
- fi
- if [[ ${EPYTHON} == python3.4 ]]; then
- ignore="--ignore=test_async_cached_property.py"
- fi
- py.test -v ${ignore} tests/ || die
-}