summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-03-01 11:37:09 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-03-01 11:37:09 +0700
commit4655132bed49431553eaf71c251f245752270929 (patch)
treea110f913649d739d585cc5926a2e9c84f0dc92f2 /dev-python
parentsphinxcontrib-github-alt: add python3_8 (diff)
downloadgentoo-4655132bed49431553eaf71c251f245752270929.tar.gz
gentoo-4655132bed49431553eaf71c251f245752270929.tar.bz2
gentoo-4655132bed49431553eaf71c251f245752270929.zip
dev-python/nose-exclude: add python3_8
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nose-exclude/nose-exclude-0.5.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/nose-exclude/nose-exclude-0.5.0-r1.ebuild b/dev-python/nose-exclude/nose-exclude-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..b3b7db5f4d84
--- /dev/null
+++ b/dev-python/nose-exclude/nose-exclude-0.5.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Exclude specific directories from nosetests runs"
+HOMEPAGE="https://github.com/kgrandis/nose-exclude"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}