summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-11 08:56:26 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-11 10:01:42 +0200
commit49197c430384e43338890d6295c36197d1d3048f (patch)
tree640c3c66c9a9a81dba4fa8a963c0bdf6884437fb /dev-python
parentdev-python/gevent: Bump to 20.6.1 (diff)
downloadgentoo-49197c430384e43338890d6295c36197d1d3048f.tar.gz
gentoo-49197c430384e43338890d6295c36197d1d3048f.tar.bz2
gentoo-49197c430384e43338890d6295c36197d1d3048f.zip
dev-python/hypothesis: Bump to 5.16.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.16.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index da5d94b119dd..cace366d3857 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-python-5.13.1.tar.gz 9010460 BLAKE2B 55e3266eb0a48e60963a3a97e18
DIST hypothesis-python-5.15.0.tar.gz 9010730 BLAKE2B 926433af6c57ee5206bc50ba96275b43c75534a31ab680042e42b4c4b01cb3d55efe76ce5355ed5407c83237c748929e04fbab570f04ad3cd6d41446b90387a5 SHA512 333547ec8433e9190508038f4263c4e65399db3cedf2f5e0af6bcd398ebcdb8614899499c3c6f0395333933b5b7e1d88dd4606243ae3aa8d763afc84bc1831e7
DIST hypothesis-python-5.15.1.tar.gz 9010924 BLAKE2B a00ebf581781e47fd85fa9d5044894d3f81e1195bbe4269e2bb2262dc70586936df33c4871b4186ff45ec49235b81a4070fc89daa67d2bcd31c98291c12be730 SHA512 d3fdc2ec2d66353da2ee790eae8ecef0bf168320a90556b5877844af975765c1da37a104765a3ca07e3143621be5cb01acfa7d19cc3222a52a0cd6eb63f6c0be
DIST hypothesis-python-5.16.0.tar.gz 9011031 BLAKE2B 65659f72094ac7fcc82c7e5a8b88c0156345530742412f13398dc72ce50d2466fa9b04b5cf4a79e87916aae770f2a89aa880d1d238890c7f8c8483c4c5068bcb SHA512 66366c172aaed84f1fb5fe0cef4e0fccfa4f65c31a94d52cf3a49b44b535f8366e71974f2aaa7b39d1d1b4171fd92cbfe4bbbac8ec4b9c4ccd2b0e5d15976d26
+DIST hypothesis-python-5.16.1.tar.gz 9011388 BLAKE2B 9d80cd296475846404ded5c466ee50f11957959f08a94a715f80e732da83bc31b66a2bbff2bb4ac1402dbeddda219eada772267f34705b8891137b8d910e5229 SHA512 ea1416c041c857fc184fcce10862d93fce1de888396527d120b2d5f3cd041084d85f8ab4b36693d52786c7162bf41d61c9700ebc4509902c6fcd1c2e87130dfb
diff --git a/dev-python/hypothesis/hypothesis-5.16.1.ebuild b/dev-python/hypothesis/hypothesis-5.16.1.ebuild
new file mode 100644
index 000000000000..494668bd6a8e
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.16.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}