summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-30 18:42:57 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-30 19:56:02 +0100
commit50458f337c6fe3fcff8a65be100f9d8f196b21a6 (patch)
treebac71300af559a9d72ff38f9c75e5494e3bf0c72 /dev-python
parentdev-python/certifi: Removed old. (diff)
downloadgentoo-50458f337c6fe3fcff8a65be100f9d8f196b21a6.tar.gz
gentoo-50458f337c6fe3fcff8a65be100f9d8f196b21a6.tar.bz2
gentoo-50458f337c6fe3fcff8a65be100f9d8f196b21a6.zip
dev-python/pygments: Bump to version 2.2.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygments/Manifest1
-rw-r--r--dev-python/pygments/pygments-2.2.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index a1de4dc6de0b..fb8c2a36f4ac 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -2,3 +2,4 @@ DIST Pygments-2.0.2.tar.gz 3462280 SHA256 7320919084e6dac8f4540638a46447a3bd730f
DIST Pygments-2.1.1.tar.gz 2114190 SHA256 2df7d9a85b56e54c7c021dc98fc877bd216ead652c10da170779c004fb59c01b SHA512 7eb35865074f573ef7d41a1f1ee7576a83c32855018d03570eb70fd6864ddfbbc3f93ae082c4ac7e4a274a0ef387ea4ccb0909423e01efb6bb8e4fefea8f2807 WHIRLPOOL 6b1ebed4b3c456ada335be87d184bfe197f489b445c362c8f1326229e137e859388e1812290bf1d7f6ed19b780dc8487fe9744863833889d961604fb9489b381
DIST Pygments-2.1.3.tar.gz 2116434 SHA256 88e4c8a91b2af5962bfa5ea2447ec6dd357018e86e94c7d14bd8cacbc5b55d81 SHA512 f6885abfa0033dc2b8894649c7a4626165af01e69268344f002efdfc536c776a9af86be4e76e5905bd31cb78096e1ed3c16d9dd4b29c6a97b4c9cc1bfd7a5b67 WHIRLPOOL c2315b8be55adc65f48675e58f946af6bf2118661beb0ab7ac149325a2d7f7b19aedef7b1ea6e070b5405c80c3b212cbe520ef23969bffb63bee1d7d6f589f41
DIST Pygments-2.1.tar.gz 2078224 SHA256 13a0ef5fafd7b16cf995bc28fe7aab0780dab1b2fda0fc89e033709af8b8a47b SHA512 4103a636a23d4a7f26c1eb98dc0d2386be17031715ceabb0f1dafb78f2635d8a7f2fe02ff7659c63fbc5c778dff9053c8ef2d916bbbab53841e2b0fafe64c213 WHIRLPOOL 81c5c5d110d2813acc12b7fb1800560189a37b51a2720dae2c9b612ec7c694fa381953491eab336a92ebf290fec505bea850fc0a8288f4b0964cfab0134dae8b
+DIST Pygments-2.2.0.tar.gz 2113944 SHA256 dbae1046def0efb574852fab9e90209b23f556367b5a320c0bcb871c77c3e8cc SHA512 cc0a4f73e19fa6cbf46314de2e809460c807c631e39ba05cbe5edb5f40db1a687aafcd9715585a0ed45f791710eb6038305e273f282f8682df76f30e63710b29 WHIRLPOOL f0562ce0b92245050657b6b8b0952bbd719ad8789434a2c87bb45594787839405bc2fcb05ed125fe1801a71739462be5be96263d27075427a4bafaa5b44e3fe7
diff --git a/dev-python/pygments/pygments-2.2.0.ebuild b/dev-python/pygments/pygments-2.2.0.ebuild
new file mode 100644
index 000000000000..4900fb9ae172
--- /dev/null
+++ b/dev-python/pygments/pygments-2.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
+
+inherit distutils-r1 bash-completion-r1 vcs-snapshot
+
+MY_PN="Pygments"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="http://pygments.org/ https://pypi.python.org/pypi/Pygments"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ virtual/ttf-fonts )"
+# dev-texlive/texlive-latexrecommended
+# Removing / commenting out this dep. I can find no mention of it in tests other than
+# importing pygment's own tex module. If it's there and I missed it just uncomment and re-add
+# Tests pass without it
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cp -r -l tests "${BUILD_DIR}"/ || die
+ # With pypy3 there is 1 error out of 1556 tests when run as is and
+ # (SKIP=8, errors=1, failures=1) when run with 2to3; meh
+ nosetests --verbosity=3 -w "${BUILD_DIR}"/tests \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+ newbashcomp external/pygments.bashcomp pygmentize
+}