summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-22 08:47:04 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-22 08:48:57 +0200
commit55e1bc588459738ebc8df0f98c7d399f563e1ac8 (patch)
treeb9e81d81a6e00bf9db7f2966e32712f99228cc3f /dev-python
parentdev-python/pyqtgraph: Remove old (diff)
downloadgentoo-55e1bc588459738ebc8df0f98c7d399f563e1ac8.tar.gz
gentoo-55e1bc588459738ebc8df0f98c7d399f563e1ac8.tar.bz2
gentoo-55e1bc588459738ebc8df0f98c7d399f563e1ac8.zip
dev-python/networkx: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/networkx/Manifest2
-rw-r--r--dev-python/networkx/metadata.xml2
-rw-r--r--dev-python/networkx/networkx-2.5.ebuild56
-rw-r--r--dev-python/networkx/networkx-2.6.1.ebuild44
4 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index 9dca0f11ce21..47bf2b6c4ca2 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1,3 +1 @@
-DIST networkx-2.5.tar.gz 1542085 BLAKE2B a4d1d1f65a09f8e7cd830a9e670cf540c19b800dffb90aa1cc6ebda8b6116b6181969382f90339254746a3f277d786020506a3c8f10c90ff48999d3b2c3c433e SHA512 ab51198072d20bdba7c9ceb6856631a20a7e9527a7cadb41271a999f57bf60da5488269c6e4e1f3f4f33420ec6493af665386842c216ea1cfadd1792ccb6444e
-DIST networkx-2.6.1.tar.gz 1842369 BLAKE2B bac0106758fa7d33000d970873ee221ee9b367ad895f2f8fbfdfb29908851c69f632214dac06c48ab433e3b6251a439199fe3675517252c959ba2a29076cc866 SHA512 132f34eb8790fb366263cfbb501ec5ca0f9c9082562215a06a114b2ec80baf72f5489f27e7fe1cbea49749eab48116e8772ff953339de0caabf37096ce097500
DIST networkx-2.6.2.tar.gz 1842077 BLAKE2B 8493e2d6a64d140b012ea443e9b1dc2409f8208dc1678c1d21cfd19bbdc07df6e9051aefe994d5fa6460db48320d563bb3051150782545ab5f671b7aafda4d0a SHA512 7006dcd209cce79f0f6cac4884797775422bd90fd3e8abb2eee70e6e00c9a25a785dd5856fc1657019a2b5c13a6fa5f705ea2e650c15a1f9d7d93580bc299219
diff --git a/dev-python/networkx/metadata.xml b/dev-python/networkx/metadata.xml
index 1183be08b85b..c143cf25c90a 100644
--- a/dev-python/networkx/metadata.xml
+++ b/dev-python/networkx/metadata.xml
@@ -23,8 +23,6 @@
</upstream>
<use>
<flag name="extras">Provide graph drawing and graph layout algorithms along with shapefile format reading and writing</flag>
- <flag name="pandas">Provides a DataFrame, which is a tabular data structure with labeled axes</flag>
- <flag name="scipy">Enables scipy backend</flag>
<flag name="yaml">Provides YAML format reading and writing</flag>
</use>
</pkgmetadata>
diff --git a/dev-python/networkx/networkx-2.5.ebuild b/dev-python/networkx/networkx-2.5.ebuild
deleted file mode 100644
index 1d68a8d37f79..000000000000
--- a/dev-python/networkx/networkx-2.5.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Python tools to manipulate graphs and complex networks"
-HOMEPAGE="https://networkx.org/ https://github.com/networkx/networkx"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="examples extras pandas scipy test xml yaml"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/decorator-4.3.0[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-2.2.2[${PYTHON_USEDEP}]
- extras? (
- >=dev-python/pydot-1.2.4[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/pygraphviz-1.5[${PYTHON_USEDEP}]
- >=sci-libs/gdal-1.10.0[python,${PYTHON_USEDEP}]
- ' python3_8)
- )
- pandas? (
- $(python_gen_cond_dep '
- >=dev-python/pandas-0.23.3[${PYTHON_USEDEP}]
- ' python3_{8..9})
- )
- scipy? ( >=dev-python/scipy-1.1.0[${PYTHON_USEDEP}] )
- xml? ( >=dev-python/lxml-4.2.3[${PYTHON_USEDEP}] )
- yaml? ( >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}] )"
-BDEPEND="
- test? (
- >=dev-python/scipy-1.1.0[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # pyyaml upgrade-related regression?
- networkx/readwrite/tests/test_yaml.py
- )
- virtx epytest -p no:django ${deselect[@]/#/--deselect }
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/networkx/networkx-2.6.1.ebuild b/dev-python/networkx/networkx-2.6.1.ebuild
deleted file mode 100644
index 51a49fc1b85c..000000000000
--- a/dev-python/networkx/networkx-2.6.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Python tools to manipulate graphs and complex networks"
-HOMEPAGE="https://networkx.org/ https://github.com/networkx/networkx"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="examples extras xml yaml"
-
-RDEPEND="
- >=dev-python/matplotlib-3.3[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
- >=dev-python/pandas-1.1[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.6.2[${PYTHON_USEDEP}]
- extras? (
- >=dev-python/pydot-1.4.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/pygraphviz-1.7[${PYTHON_USEDEP}]
- >=sci-libs/gdal-1.10.0[python,${PYTHON_USEDEP}]
- ' python3_{8..9})
- )
- xml? ( >=dev-python/lxml-4.5[${PYTHON_USEDEP}] )
- yaml? ( >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=()
- virtx epytest -p no:django ${deselect[@]/#/--deselect }
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}