summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-27 18:38:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-27 18:48:41 +0200
commit5fc42e4368e38943714c0aa4f65e2fd01a3735e6 (patch)
tree432401853887c794ba9966db863f956d34634d75 /dev-python
parentdev-python/filelock: Remove old (diff)
downloadgentoo-5fc42e4368e38943714c0aa4f65e2fd01a3735e6.tar.gz
gentoo-5fc42e4368e38943714c0aa4f65e2fd01a3735e6.tar.bz2
gentoo-5fc42e4368e38943714c0aa4f65e2fd01a3735e6.zip
dev-python/filelock: Bump to 3.10.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/filelock/Manifest1
-rw-r--r--dev-python/filelock/filelock-3.10.7.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/filelock/Manifest b/dev-python/filelock/Manifest
index f9f051954850..1dc6c32cb393 100644
--- a/dev-python/filelock/Manifest
+++ b/dev-python/filelock/Manifest
@@ -1,3 +1,4 @@
DIST filelock-3.10.6.tar.gz 10478 BLAKE2B dfb9fdc81da83b99833d5412a09ac697ee2488815672f12d798a88c7211d1d9cfe7a7300f35ce2ae6fa018784b0227a79c9ed4a3f96c881c117a6fe3b9d6c03f SHA512 82b962ee2d22788d272f6149bef3587fa2213cce4fad1c843911fcb28f1bbb529c93e09ad854a5abff5dabea0375bd9b797be4dc141b8633f590954c257173b3
+DIST filelock-3.10.7.tar.gz 10481 BLAKE2B f47f79c829154d24b12489e1ef25f500fbc49fd773de1170af168a49fbad7bfcedd89ca9dc151e6705ed0cae10c009293a175b8bded19fc69255faef7823a9ad SHA512 4ccdc6bc7d731b3854773bcc9cba47d3457ed531ca8eb41dbdbd0e10aa5f64b1f53a6dac536506c782cb93e4c354f2c815407b1514cb16b4d8f02957c9f159bd
DIST filelock-3.9.1.tar.gz 9720 BLAKE2B 4225d718f5c6e7c81e5db5d6ac2af42ce78a6c61b59f85bf8c2aafd71509b4811542e7a7648ffa2b14f3b3e762d975296c095e322e6c6ccf8fa5f1839213531d SHA512 7a240b0014a6570099106c72b376c47b7b23cddc3e70f78e2560ccccfcee31d1078d894c2e3ec6fed2f983859543a84cac03f8834df9e64fcb0a966308f7503e
DIST py-filelock-3.9.0.gh.tar.gz 205047 BLAKE2B 3995f7ad27bb09ca75310c4ada7645f2dd16c09ddb39663394f315443851037f2f9cf08eecb507eba521479696ad1004978d3fdd300a7128ac3354fce2e57d5f SHA512 1235ae9ebdb4c84b0c30e68be91e01eb1acbfcd15c85202fa54a3b91e4e507f221926f8886e1ec91acd4f71d2d88c08f536529b4cebfd2de4fb90118f5dc242e
diff --git a/dev-python/filelock/filelock-3.10.7.ebuild b/dev-python/filelock/filelock-3.10.7.ebuild
new file mode 100644
index 000000000000..86d1f81ea020
--- /dev/null
+++ b/dev-python/filelock/filelock-3.10.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="
+ https://github.com/tox-dev/py-filelock/
+ https://pypi.org/project/filelock/
+"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest