summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-19 17:53:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-19 18:41:55 +0200
commit61176136152fb9ac38da8daecd0629799cb95742 (patch)
tree5375a36a9f912929e740d4ee08302ebcece90886 /dev-python
parentsys-libs/libnih: Fix building with CFLAGS=-fno-common (diff)
downloadgentoo-61176136152fb9ac38da8daecd0629799cb95742.tar.gz
gentoo-61176136152fb9ac38da8daecd0629799cb95742.tar.bz2
gentoo-61176136152fb9ac38da8daecd0629799cb95742.zip
dev-python/binaryornot: Bump to 0.4.4, py3.{7,8}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/binaryornot/Manifest1
-rw-r--r--dev-python/binaryornot/binaryornot-0.4.4.ebuild28
-rw-r--r--dev-python/binaryornot/files/binaryornot-0.4.4-tests.patch22
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/binaryornot/Manifest b/dev-python/binaryornot/Manifest
index e5d95ea85442..0f6a5a4dc045 100644
--- a/dev-python/binaryornot/Manifest
+++ b/dev-python/binaryornot/Manifest
@@ -1 +1,2 @@
DIST binaryornot-0.4.3.tar.gz 372299 BLAKE2B c4ae99b9ccb66da8925d74fad68b8df4713822acc74d852e2f584e5c157eb465bc6418b0e0085533479ba1ee937c3d2716dea66ce3bd517d49a490ab4615f694 SHA512 bdb918b921fc46d056572b84126dbdc6605ec98cf13aac84f6f64ce07d083839be40bf7a08185eaabfbe136a9bcf0c1acc8041a23a6bb2843e8e72981222ebaa
+DIST binaryornot-0.4.4.tar.gz 372361 BLAKE2B cb2099313f602915bacd5b463642f16430fcb0ab62dcaae546cb854780996526fb777c0b730b4b89e664ec7f995ddd2d2f632cfbac2dadca45958cfd1dd7a410 SHA512 31dfb79bb5847e12487d94519a357dece4572f7ed064686d53a49c2de5a51d6441be64523c98cca6221ed89be5bf26e54866dd3b79ac8d89fd5019a5b4d75a45
diff --git a/dev-python/binaryornot/binaryornot-0.4.4.ebuild b/dev-python/binaryornot/binaryornot-0.4.4.ebuild
new file mode 100644
index 000000000000..ec80214fe93e
--- /dev/null
+++ b/dev-python/binaryornot/binaryornot-0.4.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra-lightweight pure Python package to guess whether a file is binary or text"
+HOMEPAGE="https://github.com/audreyr/binaryornot"
+SRC_URI="https://github.com/audreyr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst HISTORY.rst CONTRIBUTING.rst )
+
+PATCHES=(
+ # https://github.com/audreyr/binaryornot/commit/38dee57986c6679d9936a1da6f6c8182da3734f8
+ "${FILESDIR}"/${P}-tests.patch
+)
+
+distutils_enable_tests unittest
diff --git a/dev-python/binaryornot/files/binaryornot-0.4.4-tests.patch b/dev-python/binaryornot/files/binaryornot-0.4.4-tests.patch
new file mode 100644
index 000000000000..2070485b6a0d
--- /dev/null
+++ b/dev-python/binaryornot/files/binaryornot-0.4.4-tests.patch
@@ -0,0 +1,22 @@
+From 38dee57986c6679d9936a1da6f6c8182da3734f8 Mon Sep 17 00:00:00 2001
+From: Greg <gregobinna@gmail.com>
+Date: Sat, 10 Aug 2019 15:10:33 +0000
+Subject: [PATCH] fix failing test
+
+---
+ tests/test_check.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_check.py b/tests/test_check.py
+index 1ea31a4..f800583 100755
+--- a/tests/test_check.py
++++ b/tests/test_check.py
+@@ -216,7 +216,7 @@ def bytes_in_file(data):
+
+
+ class TestDetectionProperties(unittest.TestCase):
+- @given(binary(average_size=512))
++ @given(binary(max_size=512))
+ def test_never_crashes(self, data):
+ with bytes_in_file(data) as f:
+ is_binary(f)