summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-30 23:16:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-30 23:19:49 +0200
commit61b38a3441fecc011b966635a0600ab229ba4341 (patch)
tree9098c66dfbf622934071b3b268e8c60f70760053 /dev-python
parentdev-python/pyzmq: Skip more tests (diff)
downloadgentoo-61b38a3441fecc011b966635a0600ab229ba4341.tar.gz
gentoo-61b38a3441fecc011b966635a0600ab229ba4341.tar.bz2
gentoo-61b38a3441fecc011b966635a0600ab229ba4341.zip
dev-python/pyzmq: Bump to 22.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyzmq/Manifest1
-rw-r--r--dev-python/pyzmq/pyzmq-22.1.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index 4257e611c47a..74169a1a4a54 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1 +1,2 @@
DIST pyzmq-20.0.0.gh.tar.gz 393041 BLAKE2B 1f22f556f5d0f2755c2e56411fdb9f583bbdfad6315e4e72fbaa1fb18d0ad5436ee0ee8d17497641421cea3f4e1b53b8ff85bf7ced96c8f1c80db0be901ca3d5 SHA512 30359e501e76d6ec14175622d6c970d9ec0f227b372d2b1c6e6650be812dd47017b797a016f5a2da83f72d00536e64d2f005a38003c9a1b4fbb7266f2640782d
+DIST pyzmq-22.1.0.gh.tar.gz 401919 BLAKE2B ec43c62e68633a7e0ac06e7a717b6409e444dbd1347154c2a29a2dfb00916829656308122fa2cf0fc1e3013c82ba6bcc5e11b86582f95d46f43e9e81f6d8ff74 SHA512 aa135279927bff07339b99b4ebbc7d47effbfba7df99d3576088fe0e7d4a3ad44174a928e8b94afdeaf531c6a30cbb7bb88bce7fe19e7e5420b079ffb8e8690e
diff --git a/dev-python/pyzmq/pyzmq-22.1.0.ebuild b/dev-python/pyzmq/pyzmq-22.1.0.ebuild
new file mode 100644
index 000000000000..c1619471f402
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-22.1.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit flag-o-matic distutils-r1 toolchain-funcs
+
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="
+ https://zeromq.org/languages/python/
+ https://pypi.org/project/pyzmq/
+ https://github.com/zeromq/pyzmq/"
+SRC_URI="
+ https://github.com/zeromq/pyzmq/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+draft"
+
+DEPEND="
+ >=net-libs/zeromq-4.2.2-r2:=[drafts]
+"
+# it uses cffi backend for pypy, cython backend for cpython
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ ' pypy3)
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ "dev-python/numpydoc"
+
+python_configure_all() {
+ tc-export CC
+ append-cppflags -DZMQ_BUILD_DRAFT_API=$(usex draft '1' '0')
+}
+
+python_compile() {
+ esetup.py cython --force
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local deselect=(
+ # TODO
+ zmq/tests/test_constants.py::TestConstants::test_draft
+ zmq/tests/test_cython.py::test_cython
+
+ # hangs often
+ zmq/tests/test_log.py::TestPubLog::test_blank_root_topic
+ )
+
+ cd "${BUILD_DIR}"/lib || die
+ epytest -p no:flaky ${deselect[@]/#/--deselect } \
+ --ignore zmq/tests/test_mypy.py
+ rm -rf .hypothesis .pytest_cache || die
+}