summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-24 07:53:07 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-24 08:56:53 +0100
commit659c29504ecd09f75121024156106de577aad0fc (patch)
tree70f0a94d6b45bfdd1b14458b3f57042132342e98 /dev-python
parentdev-python/boto3: Bump to 1.17.14 (diff)
downloadgentoo-659c29504ecd09f75121024156106de577aad0fc.tar.gz
gentoo-659c29504ecd09f75121024156106de577aad0fc.tar.bz2
gentoo-659c29504ecd09f75121024156106de577aad0fc.zip
dev-python/hypothesis: Bump to 6.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.3.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 6d8cb18bdfb3..461ad63fe9da 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-python-6.0.2.tar.gz 9104422 BLAKE2B 1f932e2e2c7f3b3f56863fecfeaf
DIST hypothesis-python-6.1.1.tar.gz 9107792 BLAKE2B 50d3b284f0ab1b7c1a25fbf1488b8fea74c66aaac07d58e3271f187e54579011311ef3c20cf5525e84058382c516e6cf1495201e8b6fbd45fe28309a25fda0e0 SHA512 7d6ef548333b860dd868a9aa2a220191c237ac8e843cff835f423332fa561377ced29a9703cf0a49c76594a986048c1b1a1b8df5b38b2848410cfd7708168d58
DIST hypothesis-python-6.2.0.tar.gz 9108590 BLAKE2B 73a6b71c68aec1ec51f791187bbe5be679d5e3b4da9e66745767dafb109d298b0c61bd461ed838a0c75884d155fb408bddebc75d1cf887629da5cf5d6b053e03 SHA512 b249124f90d1d68aa6e106965b0ae78e37f095be0adc1833895f0895357d46c907074e2abe458be566708ba006b6c4375908b40ef89d52300fd41ad63abc2e52
DIST hypothesis-python-6.3.0.tar.gz 9108690 BLAKE2B 1b46da2ea5b1eafeb49df28aadbce3cb2d5e597508deaa7b84c22bc1fdd41c6de9473c338c085aec6b2e6d392afe6f9c5cf512d9b9e828c6b328a9244e11ab96 SHA512 23f4a75232abf80cd0cafe52b0ccfc47aa79f95687efeb70f30303be611192ea3fb287aaa8c9b25806c64e75b3e0fca685eb73711e170873c9c8b3af925f65e8
+DIST hypothesis-python-6.3.1.tar.gz 9112495 BLAKE2B 4c6f58911bfa45fe82681631109a9e4ad75927f6970d8fff60ec4a6d0fb2d1ec8a0b345163128b26a902e864984444947d7c96a027b26eae8a11c4f3e4fe6cd7 SHA512 6b595942ecb27684f97efb84b1c671bfcd77040516d83cb568e08a47a7add13aeb5c4f47e2e2cd3d84c52911f271d07382e4607cfcdbc751dc754bfbfb07336b
diff --git a/dev-python/hypothesis/hypothesis-6.3.1.ebuild b/dev-python/hypothesis/hypothesis-6.3.1.ebuild
new file mode 100644
index 000000000000..46ee7df74d3c
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.3.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}