summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-11 09:22:02 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-11 09:49:12 +0100
commit67d0350747ab0cc1ad7e8dc2454d0ee41700778b (patch)
tree5335e55a881874ae72eecddd2211b1ee37c6e746 /dev-python
parentdev-python/pytest-asyncio: Enable pypy3 (diff)
downloadgentoo-67d0350747ab0cc1ad7e8dc2454d0ee41700778b.tar.gz
gentoo-67d0350747ab0cc1ad7e8dc2454d0ee41700778b.tar.bz2
gentoo-67d0350747ab0cc1ad7e8dc2454d0ee41700778b.zip
dev-python/jeepney: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jeepney/Manifest1
-rw-r--r--dev-python/jeepney/jeepney-0.5.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/jeepney/Manifest b/dev-python/jeepney/Manifest
index 51662e357206..fa22b3d99df9 100644
--- a/dev-python/jeepney/Manifest
+++ b/dev-python/jeepney/Manifest
@@ -1 +1,2 @@
DIST jeepney-0.4.3.tar.gz 28121 BLAKE2B 2c9b5b5ec26a9af25d28af602827c73c8ec9377a88a4aa79b9a986675c1ef3f195763a338f3efa4ee371f7751dcf05a9f9cfed06c8d6677d81da3699773d5561 SHA512 bfb12c9259a57324759f8be44d1faf2c0535762e72db5f1370e64cb144c0fc537c9bc9cfb9b075932fb3a20e3ef4e0c990c10905cc5a69e3fb088e8de4193689
+DIST jeepney-0.5.0.tar.gz 48460 BLAKE2B 5ce1fd0315ad839cf2e0ec5616a448da840d1d3b1720528a0cd858526815b062929ebdc92916820008969092bce470c88704deb96c6120c086f631d1312985b9 SHA512 ae80a363cac4944cb6a499450835176d63e29545b8025c6dd0241a08b35e7b2564beaab578cbba319799ec5530fd6fed7e9f910e401d68b46290617e5f739992
diff --git a/dev-python/jeepney/jeepney-0.5.0.ebuild b/dev-python/jeepney/jeepney-0.5.0.ebuild
new file mode 100644
index 000000000000..93a659396779
--- /dev/null
+++ b/dev-python/jeepney/jeepney-0.5.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
+HOMEPAGE="https://gitlab.com/takluyver/jeepney"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+src_prepare() {
+ rm jeepney/io/tests/test_trio.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}