summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2018-12-22 20:39:21 +0100
committerDavide Pesavento <pesa@gentoo.org>2018-12-22 20:39:54 +0100
commit6812c957f01c2ebd972b3aa8315247d035afb1ec (patch)
tree71d6b20f694400a7b0846fb5fd26e54bc2903636 /dev-python
parentsys-process/parallel: remove old (diff)
downloadgentoo-6812c957f01c2ebd972b3aa8315247d035afb1ec.tar.gz
gentoo-6812c957f01c2ebd972b3aa8315247d035afb1ec.tar.bz2
gentoo-6812c957f01c2ebd972b3aa8315247d035afb1ec.zip
dev-python/PyQt5: use a more unique name for tmp_root
Closes: https://bugs.gentoo.org/654804 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt5/PyQt5-5.10.1-r1.ebuild4
-rw-r--r--dev-python/PyQt5/PyQt5-5.11.3.ebuild2
2 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/PyQt5/PyQt5-5.10.1-r1.ebuild b/dev-python/PyQt5/PyQt5-5.10.1-r1.ebuild
index aac34c8a33a8..8b331f240fb1 100644
--- a/dev-python/PyQt5/PyQt5-5.10.1-r1.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.10.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -169,7 +169,7 @@ src_compile() {
src_install() {
installation() {
- local tmp_root=${D%/}/tmp
+ local tmp_root=${D%/}/${PN}_tmp_root
emake INSTALL_ROOT="${tmp_root}" install
local bin_dir=${tmp_root}${EPREFIX}/usr/bin
diff --git a/dev-python/PyQt5/PyQt5-5.11.3.ebuild b/dev-python/PyQt5/PyQt5-5.11.3.ebuild
index 5eedcadd3ead..b072e6d3cd77 100644
--- a/dev-python/PyQt5/PyQt5-5.11.3.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.11.3.ebuild
@@ -163,7 +163,7 @@ src_compile() {
src_install() {
installation() {
- local tmp_root=${D}/tmp
+ local tmp_root=${D}/${PN}_tmp_root
# parallel install fails (same issue as qscintilla-python-2.10.8)
emake -j1 INSTALL_ROOT="${tmp_root}" install