summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-04-02 17:59:08 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-04-02 17:59:08 -0500
commit705a4f34ad32571b9da067ece1aaf267d08e2d96 (patch)
tree22419928244034674c4573110cc68e635fd0b3d5 /dev-python
parentmedia-sound/spotify: updated again... (diff)
downloadgentoo-705a4f34ad32571b9da067ece1aaf267d08e2d96.tar.gz
gentoo-705a4f34ad32571b9da067ece1aaf267d08e2d96.tar.bz2
gentoo-705a4f34ad32571b9da067ece1aaf267d08e2d96.zip
dev-python/python-swiftclient: bup bug 578716
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-swiftclient/Manifest1
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-3.0.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/python-swiftclient/Manifest b/dev-python/python-swiftclient/Manifest
index 5c7e376d01a2..7eee7426cd6f 100644
--- a/dev-python/python-swiftclient/Manifest
+++ b/dev-python/python-swiftclient/Manifest
@@ -1,3 +1,4 @@
DIST python-swiftclient-2.0.3.tar.gz 55405 SHA256 b8c0b11ff0397b2f2ba2145cd8de7b86a61d34d6f1af78fee536cb9ba5dee315 SHA512 fe52e49c67edae20cd9db65adbc3b54bd1b9b40b09e2c07c65eaae80d96266134fe55d86d7cfd919453077c6c08b06a51278f93a973ec6b4279295bd6e0f9d64 WHIRLPOOL 3b80a78c8d67254f94e58acb4d758d439e79ca0cb8633d7d12cceeed817d8c9f7297f2e9a2a82642cedc4def6b15d3ccd8bab922c3a7f230d151f414f0bbca15
DIST python-swiftclient-2.1.0.tar.gz 62692 SHA256 e5304cc2fc58e5f9fec87c0910109b524b3634f49a6dd82a35a28cbdf1515de8 SHA512 a49b60124093df9b1fb9ea87a356aafd21ded0a7826b04786dddc94fc1d494c38c2e99d1bd43ba23579ff595c7fabd74bc29e852349852b0bbbfa0cd95f0cac2 WHIRLPOOL 9830329cd08047c943bf8cbd41a41eaecd20ef17a886f72b2504f1568969e08d8282ec4b4b23ea9368284b027ef320a615ce4614852105768fa6c7b004732f65
DIST python-swiftclient-2.2.0.tar.gz 67374 SHA256 f41f6650150367fc2641e1536d36a68b9664db1f4cfe3e8d1de2e2b5aa41a3cb SHA512 bd60e96525a3c879e94fbb99da1d4813cb181982b753934efd32f4a8310c8ef3237a36dc8c80a78e285ace285eae7bb72b5869863f0067dec4efc713851af7fc WHIRLPOOL f0a7eb00e3d7861e79a07cb6a366aa205fdf141dcdc54519cbade576868550049c335ed9fb3f8e05cf263ac22b85f040ff7a73364a78dc4ab786c7867c7fbf87
+DIST python-swiftclient-3.0.0.tar.gz 134376 SHA256 824b8f204c5a7764de51795256e4175fdcd655ae4df85b8ae6e6ea9ec0b41f68 SHA512 4e81504876fb81bf74c3a3e034958c4783a4a9c2c426b7ae849e1968f98d9886c2299c2e67a2b366d6d4721b4635cef90ff49201ba9a4c86da9d61bfb96fa350 WHIRLPOOL d48902f331d04b3250dc6a90aa44f31d403012e10e1617a2fa52cb05b3d615293efc65a4f35872ec019254c096e44a79544d314cd1d4e6065e8e093febb3b3b7
diff --git a/dev-python/python-swiftclient/python-swiftclient-3.0.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-3.0.0.ebuild
new file mode 100644
index 000000000000..8e185200fd5c
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-3.0.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="https://launchpad.net/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ dev-python/oslo-sphinx[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/oslo-sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )"
+RDEPEND="virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]"
+
+#PATCHES=( "${FILESDIR}/CVE-2013-6396.patch" )
+
+python_prepare() {
+ sed -i '/discover/d' "${S}/test-requirements.txt" || die "sed failed"
+ sed -i '/hacking/d' "${S}/test-requirements.txt" || die "sed failed"
+ distutils-r1_python_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ testr init
+ testr run || die "tests failed under python2_7"
+ flake8 tests && einfo "run of tests folder by flake8 passed"
+ flake8 bin/swift && einfo "run of ./bin/swift by flake8 passed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( ../${P}-python2_7/doc/build/html/. )
+ distutils-r1_python_install_all
+}