summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-19 02:34:00 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-19 02:34:24 +0300
commit71534e7ede70bf89657dfe197deedf21261f3b57 (patch)
tree9cfb6aa7bd8d4b7034b45614bf91b71fad271e80 /dev-python
parentsys-kernel/gentoo-sources: amd64 stable (bug #749315) (diff)
downloadgentoo-71534e7ede70bf89657dfe197deedf21261f3b57.tar.gz
gentoo-71534e7ede70bf89657dfe197deedf21261f3b57.tar.bz2
gentoo-71534e7ede70bf89657dfe197deedf21261f3b57.zip
dev-python/python-bugzilla: Version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-bugzilla/Manifest1
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-3.0.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/Manifest b/dev-python/python-bugzilla/Manifest
index 567aa88b4c2f..4e90a1beb794 100644
--- a/dev-python/python-bugzilla/Manifest
+++ b/dev-python/python-bugzilla/Manifest
@@ -1,2 +1,3 @@
DIST python-bugzilla-2.5.0.tar.gz 110931 BLAKE2B e7a4dc0ee00abd4bd4c55aafac8a8d2902ade116b9f35d881c3ea07441b340dc247405951b5437545720c1742f54aae3c28fe64f93191a4d7f178a3cd2db7a0e SHA512 a840db5790a7f45cdcf6ef9e261d86c6b930db30ab6340a1f351b3fd32f32e4d0f6afb68af9befef5d4e84969d568471c5c236be047f6dbab52534af3570a244
DIST python-bugzilla-3.0.0.tar.gz 112525 BLAKE2B f2746091c0152779f49502fd3394e41fdd16349c93806829a06561c49d47f6d9c9ee3b75135b9d6f66dcbb95b892aa62108634ec2e5f642b25e2cce2d06d997b SHA512 1762b1eeed125f3d35f36fa2673c1e9e808209b8723c0fdbf06f3327c40d3a5795b668913d01cf91cde3e4a0516e35c82015dbb6fc575c97b82bb421525ff03f
+DIST python-bugzilla-3.0.1.tar.gz 112600 BLAKE2B b8c81b1b3f16e9b180763dcad8615c2847bf11c2a424d1fe4995091b466c202c23c072659066f66830d6d80a96a864e4148daa7a099edd2962f28345b9c9a8af SHA512 b372aa142e9e3eb456f4bba7cbc71056304ae333635c9ae85605bdcae1e5e92e13263500dba0f844c9c577bcede8ea988a753bfe23e016c8da17f3b6e9efdf3f
diff --git a/dev-python/python-bugzilla/python-bugzilla-3.0.1.ebuild b/dev-python/python-bugzilla/python-bugzilla-3.0.1.ebuild
new file mode 100644
index 000000000000..24046df4f1db
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-3.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ || ( dev-python/python-magic[${PYTHON_USEDEP}] sys-apps/file[python,${PYTHON_USEDEP}] )
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest