summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-10 10:54:05 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-10 11:18:24 +0300
commit7b6801374787e2ed583f7c1a3add9269e16cded1 (patch)
treeedff73684e85194264eca6aceffb1b28f73841f8 /dev-python
parentapp-editors/vscodium: add missing cups dep (diff)
downloadgentoo-7b6801374787e2ed583f7c1a3add9269e16cded1.tar.gz
gentoo-7b6801374787e2ed583f7c1a3add9269e16cded1.tar.bz2
gentoo-7b6801374787e2ed583f7c1a3add9269e16cded1.zip
dev-python/python-nbxmpp: add 3.2.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-nbxmpp/Manifest1
-rw-r--r--dev-python/python-nbxmpp/python-nbxmpp-3.2.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-nbxmpp/Manifest b/dev-python/python-nbxmpp/Manifest
index 0ae4a7335f87..bb18545d1a82 100644
--- a/dev-python/python-nbxmpp/Manifest
+++ b/dev-python/python-nbxmpp/Manifest
@@ -1,4 +1,5 @@
DIST python-nbxmpp-3.2.1.tar.bz2 129362 BLAKE2B bbbeb5751fc5751cffe73c9a54c3330de9a1b48041c7a7964cefdfedbf8ae2966c8f5adaa7153386eebea44568af38ec1964d612b8baf48d6f318c83705e18d8 SHA512 3ebe1169475fcd65875cb2e6079f802a7f98717957e26e7dfcab5a71b1f94e967145a430f6d959a01b39842317d858c3b6275bcd909bf65f70699536e298b6e4
DIST python-nbxmpp-3.2.2.tar.bz2 131769 BLAKE2B 51e6d090ad1461dfdb2d0f863ac31e72b1abe2e7ad273eed5105eb55cc11a0ce6ec989241d8d928400e55e7c61a720925104f92e32110e2124e63f396b68029f SHA512 bdbcdb3978c57ef6b62c9e0da57e624ab92f1d10521f5d8b096a1b654bfa0e0026eddd6814c037bf7342e2933eb76c1c67d8f7e309e3c770bd606153f09c8ebe
DIST python-nbxmpp-3.2.3.tar.bz2 131789 BLAKE2B 7cdabe3357950b8694b85bfe1c23e8742575e37d066f61a741a017a0c96f32a9bba9c3cefcf0409b818ea366f806242c711d5bb3829c3275660e03592935f732 SHA512 7b444cf58a7abc8455d8cb2e720c77ae15fec3c0c4fc6984e51e587f122b842cbecd38f9ef225346e0fa86ccf5a4cdbc3452a78f302237f5069efb626554dd02
+DIST python-nbxmpp-3.2.4.tar.bz2 131867 BLAKE2B bfe0fe559b62e0ba526adac810bf9ed4e491349ce8535ea6ab3d476a1b1c18accfeb450a327b1e81994f2960a475b872169a61aac67d1f16767bad18f6e5e223 SHA512 4ac1c69741b4c202c463ade601bb027f4a5442da1052e2657b1319f2b9bb6dd723033b3dcf175d655205f2e918ef1b7e3e93410fc812c847d2da7ceb48420d37
DIST python-nbxmpp-nbxmpp-2.0.6.tar.bz2 122203 BLAKE2B 925604002f4363f1e0b72f05c13742f4652ba565a9faa48faf8d47688f480a7f1d7585c593b0dcf07bded8c4aa3a1d02e9697742a07b9e815daec062dfb93104 SHA512 a536b25c8a6298892a51adef4b64b75ffab88ce02fb08fc07ecd1cfe2bc794262d4d58a93248439723e6e0544485da7351bb98189b0e422a1f77b01c6f6d238e
diff --git a/dev-python/python-nbxmpp/python-nbxmpp-3.2.4.ebuild b/dev-python/python-nbxmpp/python-nbxmpp-3.2.4.ebuild
new file mode 100644
index 000000000000..20ab63a80429
--- /dev/null
+++ b/dev-python/python-nbxmpp/python-nbxmpp-3.2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to use Jabber/XMPP networks in a non-blocking way"
+HOMEPAGE="
+ https://dev.gajim.org/gajim/python-nbxmpp/
+ https://pypi.org/project/nbxmpp/
+"
+SRC_URI="
+ https://dev.gajim.org/gajim/python-nbxmpp/-/archive/${PV}/${P}.tar.bz2
+"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ net-libs/libsoup[introspection]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/precis-i18n[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest