summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-02-15 20:27:29 -0500
committerVirgil Dupras <vdupras@gentoo.org>2019-02-15 20:27:29 -0500
commit8007cfbd796544dc914b61c80f80f147d61038d3 (patch)
tree08687c2de2bcd22d7b4c30e8e927e03f78174a80 /dev-python
parentdev-python/more-itertools: bump to 5.0.0 (diff)
downloadgentoo-8007cfbd796544dc914b61c80f80f147d61038d3.tar.gz
gentoo-8007cfbd796544dc914b61c80f80f147d61038d3.tar.bz2
gentoo-8007cfbd796544dc914b61c80f80f147d61038d3.zip
dev-python/more-itertools: remove old
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/more-itertools/Manifest2
-rw-r--r--dev-python/more-itertools/more-itertools-3.0.0.ebuild42
-rw-r--r--dev-python/more-itertools/more-itertools-4.3.0.ebuild38
3 files changed, 0 insertions, 82 deletions
diff --git a/dev-python/more-itertools/Manifest b/dev-python/more-itertools/Manifest
index 40f765d72a88..fee417d80e7a 100644
--- a/dev-python/more-itertools/Manifest
+++ b/dev-python/more-itertools/Manifest
@@ -1,4 +1,2 @@
-DIST more-itertools-3.0.0.tar.gz 37622 BLAKE2B dd1806f4359406ac0a57a8eefe8d6c31033177e3f1b4fd297dfcdb525df6bd5725ff16f25abb1957dcb1cacb21bf1d037a3c9def9e9469904efbe2fd336cf5b4 SHA512 575de991b6337e6416489d92b41201536397d84ff41030a2cf09ea57cc994e03dcb4dd19eda321243ceafd49c11271da43a4c4ed5a9261cf771f0b7f8e40345c
DIST more-itertools-4.2.0.tar.gz 56871 BLAKE2B 48cdba3eebea94483c5cfd9530d4bd2cacd02e893b87482a01ff1fdf10336f3c2a40d32fbb935d38320c9c47a1fd1942a48ea12ff07ae56793ecc5870fef2452 SHA512 7e205a575fb1d17ed3be9225c5c60139db41cc4b866f6d6732c955536b1d606bb7ccd92ad77e41159965abbddec3a85761d3649c28f06d52afa8476160d70e77
-DIST more-itertools-4.3.0.tar.gz 63266 BLAKE2B fcad717550931f267594f0e338def6e8d6119f28452ed8654b9e3ca073c4219f78d58d691855c4f6b4817afbe94d176077c342fe9b57ae522bc113049da97b57 SHA512 5fee3d99fd796b0f0f6b5aa99a8db22e219d3dced71fef6f4b16286fe67061dce280389b3638c55c6e5f6c828ef1286cee845d76a6861d2af66d90e995d5aa4e
DIST more-itertools-5.0.0.tar.gz 67359 BLAKE2B a2448b218eea4442cc4739a4df414ba69e0530cd6206a13c5c017a13daa297d00c08a94cec8aec0639d8b03663f4b698702f5e700ae118ae9fb5854a6d105b36 SHA512 f72c8d6c75799c39708443ba75862801ddd3fc0382c9eee7ed24ecf04cbc7d9ff6a8e35b6fff1eaccf45ddd470c2cc8959532eca32c2ff50b0a12588727c68b4
diff --git a/dev-python/more-itertools/more-itertools-3.0.0.ebuild b/dev-python/more-itertools/more-itertools-3.0.0.ebuild
deleted file mode 100644
index 337eb39858c8..000000000000
--- a/dev-python/more-itertools/more-itertools-3.0.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="More routines for operating on iterables, beyond itertools"
-HOMEPAGE="https://pypi.org/project/more-itertools/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ~ia64 ~ppc x86"
-IUSE="doc test"
-
-RDEPEND="<dev-python/six-2.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests -v -w "${BUILD_DIR}" more_itertools --with-doctest \
- || die "tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/more-itertools/more-itertools-4.3.0.ebuild b/dev-python/more-itertools/more-itertools-4.3.0.ebuild
deleted file mode 100644
index 4528d7a54516..000000000000
--- a/dev-python/more-itertools/more-itertools-4.3.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="More routines for operating on iterables, beyond itertools"
-HOMEPAGE="https://pypi.org/project/more-itertools/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-RDEPEND="<dev-python/six-2.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? ( ${RDEPEND} )
-"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- "${EPYTHON}" -m unittest discover -v || die "tests fail with ${EPYTHON}"
-}