summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-22 11:45:21 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-22 12:02:05 +0200
commit8ef50aea949005d1738bf77220c885ed5e97973b (patch)
treed0f947805c21ccf3a60b60f59f930522b17546b5 /dev-python
parentapp-admin/terraform: Version bump (v1.0.0) (diff)
downloadgentoo-8ef50aea949005d1738bf77220c885ed5e97973b.tar.gz
gentoo-8ef50aea949005d1738bf77220c885ed5e97973b.tar.bz2
gentoo-8ef50aea949005d1738bf77220c885ed5e97973b.zip
dev-python/oslo-context: Enable tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/oslo-context/oslo-context-3.1.1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/oslo-context/oslo-context-3.1.1.ebuild b/dev-python/oslo-context/oslo-context-3.1.1.ebuild
index 958d79d40512..f8156b0a6b2e 100644
--- a/dev-python/oslo-context/oslo-context-3.1.1.ebuild
+++ b/dev-python/oslo-context/oslo-context-3.1.1.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_8 )
inherit distutils-r1
DESCRIPTION="Helpers to maintain useful information about a request context"
@@ -18,6 +17,12 @@ KEYWORDS="amd64 ~arm arm64 x86"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
RDEPEND="${CDEPEND}
>=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]"
+BDEPEND="${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest