summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-28 04:16:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-28 04:35:41 +0200
commit8fba7cf1acbb7981af49c5bed923498fffa0c3d9 (patch)
treeb4ed2abe438b5da8bd9ca54cc3a31d349a0dade4 /dev-python
parentwww-plugins/chrome-binary-plugins: automated update (85.0.4181.8) (diff)
downloadgentoo-8fba7cf1acbb7981af49c5bed923498fffa0c3d9.tar.gz
gentoo-8fba7cf1acbb7981af49c5bed923498fffa0c3d9.tar.bz2
gentoo-8fba7cf1acbb7981af49c5bed923498fffa0c3d9.zip
dev-python/idna: Bump to 2.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/idna/Manifest1
-rw-r--r--dev-python/idna/idna-2.10.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/idna/Manifest b/dev-python/idna/Manifest
index 20064ac61302..2a4653132a9b 100644
--- a/dev-python/idna/Manifest
+++ b/dev-python/idna/Manifest
@@ -1,2 +1,3 @@
+DIST idna-2.10.tar.gz 175616 BLAKE2B 2b109491a5751811e6e85244133a1c66b04b577441c250e600a9cb58511f4a0350f9dc386c64ce40464bf644c7434187c61e747c8e9a422443a740ebb766fe22 SHA512 83b412de2f79a4bc86fb4bdac7252521b9d84f0be54f4fb1bde1ee13a210bbfa4b1a98247affbc7921046fb117a591316c12694c1be72865767646554c5207ac
DIST idna-2.8.tar.gz 174481 BLAKE2B 68e5dddaae30097522e4e661438d7f89a391c5a0e2f72a99e1da88e0af9380f15958d5315fccb4221e7d44a6390a7b0daa537a4752c26cd915bf2d433a4f7cc4 SHA512 8ca5cfe6350c51250bafdac7c6e4ddd54c4a5d6bf7acbcef896760a759868c8e9df1fdf550121d8512fa3eb316dcf031ec6058e03b4f66eadee21b63e2187d33
DIST idna-2.9.tar.gz 175042 BLAKE2B d111bec6c5682321967818aa3fb828d1f7bc5c056e8c7418589a7b1f9e125aadfd21c6c3329a93b894977c41ad258c4bd38db166b85c1f85c52ca2f0b5acb242 SHA512 2bd3fdae46fe7045640912872b0a3955de3abce62fd222b16ea2c997a04755acc834eeb645e5610d621c176d4b963e1d4a71228fba14efad54999cdf3c02eaf4
diff --git a/dev-python/idna/idna-2.10.ebuild b/dev-python/idna/idna-2.10.ebuild
new file mode 100644
index 000000000000..4a4a7f4a56eb
--- /dev/null
+++ b/dev-python/idna/idna-2.10.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="https://github.com/kjd/idna https://pypi.org/project/idna/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+distutils_enable_tests setup.py