summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-10-03 15:24:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-10-03 15:36:13 -0500
commit916114b04c62e368283f610fd5433adbeffced1c (patch)
treeda066502be578fc7d1fe0fb4a15e2114bb78b0bc /dev-python
parentdev-python/python-senlinclient: adding for heat (diff)
downloadgentoo-916114b04c62e368283f610fd5433adbeffced1c.tar.gz
gentoo-916114b04c62e368283f610fd5433adbeffced1c.tar.bz2
gentoo-916114b04c62e368283f610fd5433adbeffced1c.zip
dev-python/aodhclient: adding for heat
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aodhclient/Manifest1
-rw-r--r--dev-python/aodhclient/aodhclient-0.6.0.ebuild38
-rw-r--r--dev-python/aodhclient/metadata.xml19
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/aodhclient/Manifest b/dev-python/aodhclient/Manifest
new file mode 100644
index 000000000000..98f6f54536e8
--- /dev/null
+++ b/dev-python/aodhclient/Manifest
@@ -0,0 +1 @@
+DIST aodhclient-0.6.0.tar.gz 40827 SHA256 eb33dd5b215a137d052cdbf12d9c7a2ab3d1fe52702ffd2323e57d2fa759363d SHA512 daa3f568cc2c59a010024beecf2917bf7e3ee64a0a18851e19c92dba159fcd2f36e64dd418ac4a36ee93b0a06c8c00b1f222aebfa915e9bddeaca074a12568bc WHIRLPOOL 2e71b890b392f6c00abe2c5fb45dfdf98215403612de2d50f19c4c9a82cde91c5cd7691fe51c3838ab6a7009824dfa01ca1430b95c86a9ac41fdea005758e915
diff --git a/dev-python/aodhclient/aodhclient-0.6.0.ebuild b/dev-python/aodhclient/aodhclient-0.6.0.ebuild
new file mode 100644
index 000000000000..a52e007cbde0
--- /dev/null
+++ b/dev-python/aodhclient/aodhclient-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Aodh API"
+HOMEPAGE="https://github.com/openstack/python-aodhclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/cliff-1.14.0[${PYTHON_USEDEP}]
+ !~dev-python/cliff-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.10.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.3.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # built in...
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/aodhclient/metadata.xml b/dev-python/aodhclient/metadata.xml
new file mode 100644
index 000000000000..b28e1b0716b5
--- /dev/null
+++ b/dev-python/aodhclient/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a client for the OpenStack Aodh API.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">python-aodhclient</remote-id>
+ <remote-id type="github">openstack/python-aodhclient</remote-id>
+ </upstream>
+</pkgmetadata>