summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-10-12 14:27:39 -0700
committerZac Medico <zmedico@gentoo.org>2016-10-12 14:39:04 -0700
commit9614e4e20df71e9ebe5aa8a48afc1a36c7acc03e (patch)
treec6c7f9f02a092f91a502f6d9a7e5e908eb8018de /dev-python
parentwww-apps/tt-rss: Fix mysql->mysqli transition (diff)
downloadgentoo-9614e4e20df71e9ebe5aa8a48afc1a36c7acc03e.tar.gz
gentoo-9614e4e20df71e9ebe5aa8a48afc1a36c7acc03e.tar.bz2
gentoo-9614e4e20df71e9ebe5aa8a48afc1a36c7acc03e.zip
dev-python/kombu: version bump to 3.0.37
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/kombu/Manifest1
-rw-r--r--dev-python/kombu/kombu-3.0.37.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/dev-python/kombu/Manifest b/dev-python/kombu/Manifest
index a78c1d414d8a..a61c949a165e 100644
--- a/dev-python/kombu/Manifest
+++ b/dev-python/kombu/Manifest
@@ -5,3 +5,4 @@ DIST kombu-3.0.30.tar.gz 380706 SHA256 b902fe768ea49173c7c26b117bf6c51d258f822d0
DIST kombu-3.0.32.tar.gz 380958 SHA256 d3edda02076ae04fa62d128007756f4c4298fe479119ca070a47a22afe867660 SHA512 ffdccbdb9ddde28b5eb159dcc9697d48dddfbb1b74f9f9ced8eed92a25e53d21b5e2aa3a770b014397c73a92102a9d8dc9839bcdd1f49e1700fdfd79c5fcf022 WHIRLPOOL e7af358e76088039c8a407a2ea383208be4e4b5e37965dd88fae690dd7b7117829ac2d5c49f22374d8425f92a6c651520955526b1342dd7b5ed407d50f0d56d2
DIST kombu-3.0.33.tar.gz 379423 SHA256 853d18ca958a598787ceb8c297a369745b82965bf28276861272f14745977999 SHA512 1f2772b79087038f5ec802fc8c1d511dc5e1de9bb663fb36878b5af4b0f925f83961e80a34f8a71af6d78fd45c719dfc62275923353ff38d06af5dae361f2059 WHIRLPOOL e55cdcaa550e1829b0d7cd00e03c63983f9a5525a6587428eabac6bc3379c1ba85e47173ffd14047edfc54f10391145c19fc0621074798fa7bb1e34b400f6fce
DIST kombu-3.0.34.tar.gz 380374 SHA256 8878ff19b09d86b2689682a4a3eb163d70115ef4ebd974966079a0edd80075da SHA512 9de5d9e4784d814f8c40633bfac08a4e9279d55d2122d1cfdee6418066ba61e0ef7dcaba9cf21d2b0b99989ba292125bbe4b38be90ecc288cb038aea638d1508 WHIRLPOOL d0dfe755af559f4c1d0e8fb6bbe3c7767874a34db57f4958196b853147061e078fac9d5ab31957ab88707220e738a05248afa5d86d9fbdd1a5619aab80d9711a
+DIST kombu-3.0.37.tar.gz 411790 SHA256 e064a00c66b4d1058cd2b0523fb8d98c82c18450244177b6c0f7913016642650 SHA512 ba9bb00e23ce2d3da87eb07aacff8d63ef9879e6ca9f3fe82653cc2ee91610199fe8fc778d7c2e00df05b46130ecda0bdeceda48192b8af1fb0eca41fbb44712 WHIRLPOOL 1e3344eb25024e94d341a3928bd04a9fd13bb41fefd7254e5f2dd70a8b235ae48b93d9b003b21d9ccde4ebdb8d1f349d9af6d54b51c74d6c6b1ee7913ee06919
diff --git a/dev-python/kombu/kombu-3.0.37.ebuild b/dev-python/kombu/kombu-3.0.37.ebuild
new file mode 100644
index 000000000000..27bb007610a5
--- /dev/null
+++ b/dev-python/kombu/kombu-3.0.37.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="AMQP Messaging Framework for Python"
+HOMEPAGE="https://pypi.python.org/pypi/kombu https://github.com/celery/kombu"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="amqplib doc examples msgpack sqs test"
+
+# couchdb backend support possible via dev-python/couchdb-python
+# ditto dev-python/kazoo(>=1.3.1) and dev-python/beanstalkc
+PY27_GEN_USEDEP=$(python_gen_usedep python2_7)
+PYPY_GEN_USEDEP=$(python_gen_usedep python2_7 pypy)
+RDEPEND="
+ >=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
+ >=dev-python/py-amqp-1.4.9[${PYTHON_USEDEP}]
+ <dev-python/py-amqp-2.0[${PYTHON_USEDEP}]
+ dev-python/pyro:4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/pyzmq-13.1.0[${PYTHON_USEDEP}]' 'python*')
+ amqplib? ( >=dev-python/amqplib-1.0.2[${PYTHON_USEDEP}] )
+ sqs? ( >=dev-python/boto-2.13.3[${PY27_GEN_USEDEP}] )
+ msgpack? ( >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}] )"
+# Fix to https://github.com/celery/kombu/issues/474 obliges dev-python/pymongo to >=-3.0.2
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.7[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/unittest2-0.5.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-0.7.0[${PYPY_GEN_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-2.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/beanstalkc[${PY27_GEN_USEDEP}]
+ dev-python/couchdb-python[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-issuetracker-0.9[${PYTHON_USEDEP}] )"
+
+# kazoo and sqlalchemy are optional packages for tests.
+# Refrain for now, no established demand for it from users
+
+# Req'd for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PY27_REQUSE="$(python_gen_useflags 'python2.7')"
+REQUIRED_USE="
+ sqs? ( ${PY27_REQUSE} )
+ doc? ( ${PY27_REQUSE} amqplib sqs )" # 2 deps in doc build are py2 capable only
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-NA-tests-fix.patch
+ )
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
+}
+
+python_prepare_all() {
+ # https://github.com/celery/kombu/issues/246
+ sed -e 's:kombu.transports:kombu.transport:' -i funtests/tests/test_django.py
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # Doc build must be done by py2.7
+ # Doc build misses and skips only content re librabbitmq which is not in portage
+ if use doc; then
+ emake -C docs html || die "kombu docs failed installation"
+ fi
+}
+
+python_test() {
+ export DJANGO_SETTINGS_MODULE="django.conf"
+ # https://github.com/celery/kombu/issues/474
+ # tests need </pymongo-3.0; known to cause some breakage
+ if python_is_python3; then
+ 2to3 --no-diffs -w build/lib/kombu/transport/
+ nosetests --py3where=build/lib kombu/tests || die "Tests failed under ${EPYTHON}"
+ else
+ nosetests "${S}"/kombu/tests || die "Tests failed under ${EPYTHON}"
+ # funtests appears to be coded only for py2, a kind of 2nd tier. pypy fails 6.
+ # https://github.com/celery/kombu/issues/411
+ # Fix to https://github.com/celery/kombu/issues/474 breaks the
+ # funtests under >=dev-python/pymongo-3.0.2
+# if [[ "${EPYTHON}" == python2.7 ]]; then
+# pushd funtests > /dev/null
+# esetup.py test
+# popd > /dev/null
+# fi
+ fi
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( docs/.build/html/. )
+ distutils-r1_python_install_all
+}