summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-04-19 13:14:57 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-04-19 13:31:03 -0500
commit97c385955c73a5d8e65b3fb677039cfc3c89bc8c (patch)
tree437b3d3a55b61331bd95fe567ef5bad2501dd90d /dev-python
parentgnome-extra/gnome-integration-spotify: add py37/38 tags (diff)
downloadgentoo-97c385955c73a5d8e65b3fb677039cfc3c89bc8c.tar.gz
gentoo-97c385955c73a5d8e65b3fb677039cfc3c89bc8c.tar.bz2
gentoo-97c385955c73a5d8e65b3fb677039cfc3c89bc8c.zip
dev-python/python-augeas: 1.1.0 bump
Closes: https://bugs.gentoo.org/718110 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-augeas/Manifest1
-rw-r--r--dev-python/python-augeas/files/remove-tests.patch11
-rw-r--r--dev-python/python-augeas/metadata.xml3
-rw-r--r--dev-python/python-augeas/python-augeas-1.1.0.ebuild27
4 files changed, 39 insertions, 3 deletions
diff --git a/dev-python/python-augeas/Manifest b/dev-python/python-augeas/Manifest
index c6994584ef55..77652a4ed68f 100644
--- a/dev-python/python-augeas/Manifest
+++ b/dev-python/python-augeas/Manifest
@@ -1,2 +1,3 @@
DIST python-augeas-0.5.0.tar.gz 90667 BLAKE2B 5d563350c3f80db45aad87326c445e93e3563ca6eb8de17889cdc91735c61dfcf0fda4e93f15c0d450ee156d57cb71598f32cdce6f6716b0fd610b793f103641 SHA512 d93d9e21c720084ee3c1841a2172dd1a4cfb41e668de0f557bd214efd65e685a1e5fc713a7d34e0fed727fe908bb1e8a09a1c10587bc27f3708cbcdee575cc51
DIST python-augeas-1.0.3.tar.gz 92747 BLAKE2B 0dda6ae6bbac1689c633301b91877cca4cf20773a3bf83bfd8a809dfc973da011cbeb39ed12f34b67f8f1be50ce5b9fc89e9cc7abbc992117853c11851b18fab SHA512 737b41e7bb438d80da75b55714c3f0b1706a4b2cacddd20fadf855bc3044e532f4079319b3775032e6f6009cf7f282af33fdf583332772b443a6c2d4925639fa
+DIST python-augeas-1.1.0.tar.gz 93657 BLAKE2B 21d2713d8e11552cc7f0191d2b8f7805b223f5dc9478b89b39dcbd325ab354cef0bfc0314852dc2b071b3b061319b4e27904c0514eb6d6ffd4e39cf7ca33d1f9 SHA512 34e4e98219b9146ef843d94c2e854e951a9b7e81409e603e77e7defdbb8765c013a2c869a4f5db2244352ca35656e18667a0210dd24099cb3e4552a04b23aef8
diff --git a/dev-python/python-augeas/files/remove-tests.patch b/dev-python/python-augeas/files/remove-tests.patch
new file mode 100644
index 000000000000..42f815047283
--- /dev/null
+++ b/dev-python/python-augeas/files/remove-tests.patch
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -18,7 +18,7 @@ setup(name=name,
+ author="Harald Hoyer",
+ author_email="augeas-devel@redhat.com",
+ description="""Python bindings for Augeas""",
+- packages=find_packages(exclude=('test')),
++ packages=find_packages(exclude=('test',)),
+ setup_requires=["cffi>=1.0.0"],
+ cffi_modules=["augeas/ffi.py:ffi"],
+ install_requires=["cffi>=1.0.0"],
diff --git a/dev-python/python-augeas/metadata.xml b/dev-python/python-augeas/metadata.xml
index 08cc0a07f306..27a547e80d22 100644
--- a/dev-python/python-augeas/metadata.xml
+++ b/dev-python/python-augeas/metadata.xml
@@ -4,9 +4,6 @@
<maintainer type="person">
<email>prometheanfire@gentoo.org</email>
</maintainer>
- <longdescription lang="en">
-python-augeas is a set of Python bindings around augeas.
- </longdescription>
<upstream>
<remote-id type="pypi">python-augeas</remote-id>
<remote-id type="github">hercules-team/python-augeas</remote-id>
diff --git a/dev-python/python-augeas/python-augeas-1.1.0.ebuild b/dev-python/python-augeas/python-augeas-1.1.0.ebuild
new file mode 100644
index 000000000000..42d631372089
--- /dev/null
+++ b/dev-python/python-augeas/python-augeas-1.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="app-admin/augeas
+ >=dev-python/cffi-1.0.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/remove-tests.patch" )
+
+python_test() {
+ cd test && "${PYTHON}" test_augeas.py || die
+}