summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2019-11-16 20:27:21 +0100
committerDavide Pesavento <pesa@gentoo.org>2019-11-16 20:27:56 +0100
commit99d4d129c9357904a5eb6be4e80f9f6563ff0db9 (patch)
tree9613cd83936e715b67bf6729266d0d4d97a84960 /dev-python
parentdev-python/sip: update changelog URL in metadata (diff)
downloadgentoo-99d4d129c9357904a5eb6be4e80f9f6563ff0db9.tar.gz
gentoo-99d4d129c9357904a5eb6be4e80f9f6563ff0db9.tar.bz2
gentoo-99d4d129c9357904a5eb6be4e80f9f6563ff0db9.zip
dev-python/PyQt5-sip: drop 4.19.18
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt5-sip/Manifest1
-rw-r--r--dev-python/PyQt5-sip/PyQt5-sip-4.19.18.ebuild94
-rw-r--r--dev-python/PyQt5-sip/metadata.xml2
3 files changed, 1 insertions, 96 deletions
diff --git a/dev-python/PyQt5-sip/Manifest b/dev-python/PyQt5-sip/Manifest
index 9c02d691438f..32a7a27c7818 100644
--- a/dev-python/PyQt5-sip/Manifest
+++ b/dev-python/PyQt5-sip/Manifest
@@ -1,3 +1,2 @@
DIST sip-4.19.17.tar.gz 1056156 BLAKE2B b5a7b4cd3f2152e9b7ee7b715c3ad72c2092598e0405cefc24d6283e9da07e54fd65da89e137618d3b84f3138fff719cf226600135d646e7bd7c538c2a02cdfd SHA512 d393cfc1643663926bd315a8df92abd82bec071bf0488b047625bdac43e9074bc8a510ac23244a7a2d2d181f70af9691db9d0b759e79643981d6afd71a49d3cb
-DIST sip-4.19.18.tar.gz 1056840 BLAKE2B 6c674405e28a64c9db635deca8a00ed78bf52d2551ed578a57d31ae96071ca77ba49e3fc92329942ca61de78bc98049694cc48ef54ea645819fc48f2fae56060 SHA512 e3c58cc6c38b277b3b9fd7adf33df91b47e0385e59d52c543e630a194d73d04d91e0a3845cb3973d1955f77049e75246fa7e6f544e02e1efe0086a297cf1d887
DIST sip-4.19.19.tar.gz 1058422 BLAKE2B 9c27e636a55699e8bf9c9caba9227e3ff9c8476dfd86d4bb8b0b53c9db95d28441d1ac03a0d20a71468d39e5f21066475018cff93b96281b3904f6a619304f92 SHA512 396c625f59ccef67c2e94221b26dd4ed5d536652a9b63a9f23b340ddf16adf34c6bdb0fbd7c0c1cc403e1d59e8ebf716b478a24bade66a2703fcc5f00b62533d
diff --git a/dev-python/PyQt5-sip/PyQt5-sip-4.19.18.ebuild b/dev-python/PyQt5-sip/PyQt5-sip-4.19.18.ebuild
deleted file mode 100644
index 5c2245942214..000000000000
--- a/dev-python/PyQt5-sip/PyQt5-sip-4.19.18.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-inherit python-r1 toolchain-funcs
-
-DESCRIPTION="Private sip module for PyQt5"
-HOMEPAGE="https://www.riverbankcomputing.com/software/sip/intro"
-
-MY_PN=sip
-MY_P=${MY_PN}-${PV/_pre/.dev}
-if [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
-else
- SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
-fi
-
-# Sub-slot based on SIP_API_MAJOR_NR from siplib/sip.h
-SLOT="0/12"
-LICENSE="|| ( GPL-2 GPL-3 SIP )"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- !<dev-python/PyQt5-5.12.2
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- # Sub-slot sanity check
- local sub_slot=${SLOT#*/}
- local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h || die)
- if [[ ${sub_slot} != ${sip_api_major_nr} ]]; then
- eerror
- eerror "Ebuild sub-slot (${sub_slot}) does not match SIP_API_MAJOR_NR (${sip_api_major_nr})"
- eerror "Please update SLOT variable as follows:"
- eerror " SLOT=\"${SLOT%%/*}/${sip_api_major_nr}\""
- eerror
- die "sub-slot sanity check failed"
- fi
-
- default
-}
-
-src_configure() {
- configuration() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- fi
-
- local myconf=(
- "${PYTHON}"
- "${S}"/configure.py
- --sip-module PyQt5.sip
- --sysroot="${ESYSROOT}/usr"
- --no-tools
- AR="$(tc-getAR) cqs"
- CC="$(tc-getCC)"
- CFLAGS="${CFLAGS}"
- CFLAGS_RELEASE=
- CXX="$(tc-getCXX)"
- CXXFLAGS="${CXXFLAGS}"
- CXXFLAGS_RELEASE=
- LINK="$(tc-getCXX)"
- LINK_SHLIB="$(tc-getCXX)"
- LFLAGS="${LDFLAGS}"
- LFLAGS_RELEASE=
- RANLIB=
- STRIP=
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- emake DESTDIR="${D}" install
- }
- python_foreach_impl run_in_build_dir installation
-
- einstalldocs
-}
diff --git a/dev-python/PyQt5-sip/metadata.xml b/dev-python/PyQt5-sip/metadata.xml
index 8c05084f0625..91bdf6926774 100644
--- a/dev-python/PyQt5-sip/metadata.xml
+++ b/dev-python/PyQt5-sip/metadata.xml
@@ -10,7 +10,7 @@
<email>phil@riverbankcomputing.com</email>
<name>Phil Thompson</name>
</maintainer>
- <changelog>https://www.riverbankcomputing.com/static/Downloads/sip/ChangeLog</changelog>
+ <changelog>https://www.riverbankcomputing.com/hg/sip/raw-file/tip/NEWS</changelog>
<doc>https://www.riverbankcomputing.com/static/Docs/sip/</doc>
<bugs-to>mailto:pyqt@riverbankcomputing.com</bugs-to>
<remote-id type="pypi">PyQt5-sip</remote-id>