summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-31 23:40:19 +0800
committerIan Delaney <idella4@gentoo.org>2015-08-31 23:40:19 +0800
commita34b4f77e0567f61197feba15f52a132a1064cf0 (patch)
tree8f955ad6eb28a69db919e97d7cf2a0ad3becca2d /dev-python
parentkde-misc/kde-gtk-config: improve kde-base/kdelibs-4.14.11 compatibility patch (diff)
downloadgentoo-a34b4f77e0567f61197feba15f52a132a1064cf0.tar.gz
gentoo-a34b4f77e0567f61197feba15f52a132a1064cf0.tar.bz2
gentoo-a34b4f77e0567f61197feba15f52a132a1064cf0.zip
dev-python/scrapy: bump; update and tidy deps
update test phase to run full testsuite, disable failing tests while upstream makes a fix, remove old Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/scrapy/Manifest3
-rw-r--r--dev-python/scrapy/scrapy-0.25.1.ebuild65
-rw-r--r--dev-python/scrapy/scrapy-1.0.3.ebuild (renamed from dev-python/scrapy/scrapy-1.0.0.ebuild)39
3 files changed, 28 insertions, 79 deletions
diff --git a/dev-python/scrapy/Manifest b/dev-python/scrapy/Manifest
index 1856c8064f62..ca5d0ae66b09 100644
--- a/dev-python/scrapy/Manifest
+++ b/dev-python/scrapy/Manifest
@@ -1,3 +1,2 @@
-DIST scrapy-0.25.1.tar.gz 986555 SHA256 11e6496b7196239f395c977c432667466cdef6984dff164337bca7aa37049ed5 SHA512 7c1afbf942c06ab6a849fe609ad8d582de5d42041181bb22b2388bfe13ce23438c3c6ce936953f819e4b897aadbf682cc04f8cd0805f44157b10a583c668f924 WHIRLPOOL 692f0e11065d9b149d7bdcdd9414d718f05986767a5cd3632ad3f5db23904b42a5af5609468f2bc321f827d6e3352eb0ce36cb797d68228c608ae8fa57f940c4
-DIST scrapy-1.0.0.tar.gz 1006570 SHA256 3ae419f876902e376abe6de207f91ea383ce1e385d21784965a90617985fb1d6 SHA512 72bd686da3e4d789ca51b5f90f726ece678f64dcbfe7f25cd2c377536ece9ec8c9cf49fc018ef383a910f190a32e46e7894fd165d34e191249f7bd9ae018499f WHIRLPOOL f9b26256c0d0b0ba4d088538b3f6d967eb6f0294312da61adc2d2a790bc4851555f019b1e139f7c3a83b4922065593a41606f155d9b953ded2124e551af2d194
DIST scrapy-1.0.1.tar.gz 1006619 SHA256 713ffd19616057d10addea2cba92cb6eee1642f59c803942b029cd02baa1be37 SHA512 99a6c99816c94c936c87c3f282bcc3866786b4d1adc57e00c8812c3761ef05279f0ded6746d3fdc947496549d22090f59a22392b207d56b24ca537b0e1e30372 WHIRLPOOL 3e3aef1d5416c009903a6a37df5e3f33237a50555a6dd09bde4ed6fe303473f1ef44501a04754f3d1ab2fe61668c6f7f56d507a77d89060b6fca7054f05af65c
+DIST scrapy-1.0.3.tar.gz 1006911 SHA256 725eb5906b35076ad112b1b0ac27c68dd684e72514eddf95bc7ace64c04b2bb2 SHA512 bf61d449d7309de0ebdc36c73371d01518ee5cfa5d4ac1b68ee42389466ee15dba82690dbc885aa6bc1b9fe0b2e29a03fb3a3af3889842e1039e3a81749fc0c0 WHIRLPOOL 0dee3a82a0368f50420d484252d5d138c8a3bf8257715dad5d74419a7a852ef5d21aef5b52e9959f8f08d7dcdd58988221faff38d9a8d530406cfb83fbb031f9
diff --git a/dev-python/scrapy/scrapy-0.25.1.ebuild b/dev-python/scrapy/scrapy-0.25.1.ebuild
deleted file mode 100644
index eb5cd997d443..000000000000
--- a/dev-python/scrapy/scrapy-0.25.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit vcs-snapshot distutils-r1
-
-DESCRIPTION="A high-level Python Screen Scraping framework"
-HOMEPAGE="http://scrapy.org https://pypi.python.org/pypi/Scrapy/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="boto doc ibl test ssl"
-
-RDEPEND=">=dev-python/six-1.5.2[${PYTHON_USEDEP}]
- dev-libs/libxml2[python,${PYTHON_USEDEP}]
- virtual/python-imaging[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- ibl? ( dev-python/numpy[${PYTHON_USEDEP}] )
- ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
- boto? ( dev-python/boto[${PYTHON_USEDEP}] )
- >=dev-python/twisted-core-10.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-conch-10.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-mail-10.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-10.0.0[${PYTHON_USEDEP}]
- >=dev-python/w3lib-1.6[${PYTHON_USEDEP}]
- dev-python/queuelib[${PYTHON_USEDEP}]
- >=dev-python/cssselect-0.9[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND}
- dev-python/boto[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=net-proxy/mitmproxy-0.10[${PYTHON_USEDEP}]
- net-ftp/vsftpd )"
-# pytest-twisted listed as a test dep but not in portage.
-# Testsuite currently survives without it, so appears optional
-
-REQUIRED_USE="test? ( ssl boto )"
-
-PATCHES=( "${FILESDIR}"/${PV}-setup.patch )
-
-python_compile_all() {
- if use doc; then
- PYTHONPATH="${S}" emake -C docs html || die "emake html failed"
- fi
-}
-
-python_test() {
- py.test ${PN} || die "tests failed"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/scrapy/scrapy-1.0.0.ebuild b/dev-python/scrapy/scrapy-1.0.3.ebuild
index 1f58a0d6cd4a..21f1be088b97 100644
--- a/dev-python/scrapy/scrapy-1.0.0.ebuild
+++ b/dev-python/scrapy/scrapy-1.0.3.ebuild
@@ -10,7 +10,7 @@ PYTHON_REQ_USE="sqlite(+)"
inherit vcs-snapshot distutils-r1
DESCRIPTION="A high-level Python Screen Scraping framework"
-HOMEPAGE="http://scrapy.org https://pypi.python.org/pypi/Scrapy/"
+HOMEPAGE="https://github.com/scrapy/scrapy/ http://pypi.python.org/pypi/Scrapy/"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
@@ -18,28 +18,30 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="boto doc ibl test ssl"
-RDEPEND=">=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
dev-libs/libxml2[python,${PYTHON_USEDEP}]
virtual/python-imaging[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
ibl? ( dev-python/numpy[${PYTHON_USEDEP}] )
ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
boto? ( dev-python/boto[${PYTHON_USEDEP}] )
- >=dev-python/twisted-core-10.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-conch-10.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-mail-10.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-10.0.0[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-conch[${PYTHON_USEDEP}]
+ dev-python/twisted-mail[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
>=dev-python/w3lib-1.8.0[${PYTHON_USEDEP}]
dev-python/queuelib[${PYTHON_USEDEP}]
- >=dev-python/cssselect-0.9[${PYTHON_USEDEP}]"
+ >=dev-python/cssselect-0.9[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ "
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( ${RDEPEND}
- dev-python/boto[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
- >=net-proxy/mitmproxy-0.10.1[${PYTHON_USEDEP}]
- ~dev-python/netlib-0.10.1[${PYTHON_USEDEP}]
+ =net-proxy/mitmproxy-0.10.1[${PYTHON_USEDEP}]
+ =dev-python/netlib-0.10.1[${PYTHON_USEDEP}]
dev-python/jmespath[${PYTHON_USEDEP}]
dev-python/testfixtures[${PYTHON_USEDEP}]
net-ftp/vsftpd )"
@@ -48,6 +50,19 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
REQUIRED_USE="test? ( ssl boto )"
+python_prepare_all() {
+ # https://github.com/scrapy/scrapy/issues/1464
+ # Disable failing tests known to pass according to upstream
+ # Awaiting a fix planned by package owner.
+ sed -e 's:test_https_connect_tunnel:_&:' \
+ -e 's:test_https_connect_tunnel_error:_&:' \
+ -e 's:test_https_tunnel_auth_error:_&:' \
+ -e 's:test_https_tunnel_without_leak_proxy_authorization_header:_&:' \
+ -i tests/test_proxy_connect.py || die
+
+ distutils-r1_python_prepare_all
+}
+
python_compile_all() {
if use doc; then
PYTHONPATH="${S}" emake -C docs html || die "emake html failed"
@@ -55,7 +70,7 @@ python_compile_all() {
}
python_test() {
- py.test ${PN} || die "tests failed"
+ py.test ${PN} tests || die "tests failed"
}
python_install_all() {