summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-20 13:18:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-20 16:19:31 +0200
commita359a04a47e086d8b2c893023245aa36d2206b0c (patch)
tree160840498ab502cfb0b9d41fd87809a233b38000 /dev-python
parentmedia-fonts/liberation-fonts: EAPI-7 bump (diff)
downloadgentoo-a359a04a47e086d8b2c893023245aa36d2206b0c.tar.gz
gentoo-a359a04a47e086d8b2c893023245aa36d2206b0c.tar.bz2
gentoo-a359a04a47e086d8b2c893023245aa36d2206b0c.zip
dev-python/nose2: 0.9.1 version bump, EAPI-7 bump
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nose2/Manifest1
-rw-r--r--dev-python/nose2/nose2-0.9.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/nose2/Manifest b/dev-python/nose2/Manifest
index 12a4c2e18fab..1c8a420e70fb 100644
--- a/dev-python/nose2/Manifest
+++ b/dev-python/nose2/Manifest
@@ -1 +1,2 @@
DIST nose2-0.6.5.tar.gz 134808 BLAKE2B 5f094d537ff7c48b7bfaf139b4c96a93875013ca5663d1e5b3feec543e7efd55335488321bcdd5752529cb36685dd28c91bd29665aed9e5f58fef837e5e2944b SHA512 fc84aa19d486ff1441dd43666182212e4a05b3be054f3c8967e36e624c08ee6eb10b01bba45b5f5dbbd38cfd057d53877e0bc0d9aba59b842688a5d4ec944b40
+DIST nose2-0.9.1.tar.gz 152411 BLAKE2B 39f2d992e5cab4b9e5cd4401ea9285884eeeac7d2e126b5aad5582186efa0f325139480a446950019e91a376b5992fea106064e5170c9ea7961f128b895a335c SHA512 48cfe3956a3cb696e344ea03e5e0ac8d52831b8272b7cad2bdee34681d1e4e7968fe9da9b71cc9db40b6edf289509c2af766e73611f3a6f23ebd5062f4d52c9e
diff --git a/dev-python/nose2/nose2-0.9.1.ebuild b/dev-python/nose2/nose2-0.9.1.ebuild
new file mode 100644
index 000000000000..32043d32695c
--- /dev/null
+++ b/dev-python/nose2/nose2-0.9.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Next generation unittest with plugins"
+HOMEPAGE="https://github.com/nose-devs/nose2"
+SRC_URI="https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-1.0.5[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ >=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.1[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ >=dev-python/cov-core-1.12[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -m nose2.__main__ || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}