summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-22 08:24:27 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-22 08:26:16 +0100
commita53f20a6c1c7157c3b21b2c73fd090a635956150 (patch)
treefcd0af41cce09704b7c63ab4dcae189b10468827 /dev-python
parentdev-python/urllib3: Enable testing on py3.8 (diff)
downloadgentoo-a53f20a6c1c7157c3b21b2c73fd090a635956150.tar.gz
gentoo-a53f20a6c1c7157c3b21b2c73fd090a635956150.tar.bz2
gentoo-a53f20a6c1c7157c3b21b2c73fd090a635956150.zip
dev-python/urllib3: Fix some of the tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/urllib3/urllib3-1.25.8.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/dev-python/urllib3/urllib3-1.25.8.ebuild b/dev-python/urllib3/urllib3-1.25.8.ebuild
index ef0f1ab8a4a3..e21205e47f94 100644
--- a/dev-python/urllib3/urllib3-1.25.8.ebuild
+++ b/dev-python/urllib3/urllib3-1.25.8.ebuild
@@ -49,12 +49,9 @@ distutils_enable_sphinx docs \
dev-python/mock
python_prepare_all() {
- # tests requiring a route to be present
- sed -e 's:test_enhanced_timeout:_&:' \
- -e 's:test_https_timeout:_&:' \
- -i test/with_dummyserver/test_https.py || die
- sed -e 's:test_https_proxy_.*timeout:_&:' \
- -i test/with_dummyserver/test_proxy_poolmanager.py || die
+ # https://github.com/urllib3/urllib3/issues/1756
+ sed -e 's:10.255.255.1:240.0.0.0:' \
+ -i test/__init__.py || die
# tests failing if 'localhost.' cannot be resolved
sed -e 's:test_dotted_fqdn:_&:' \
-i test/with_dummyserver/test_https.py || die
@@ -64,9 +61,7 @@ python_prepare_all() {
# very flaky
sed -e 's:test_client_no_intermediate:_&:' \
-i test/with_dummyserver/test_https.py || die
- sed -e 's:test_cross_host_redirect:_&:' \
- -e 's:test_cross_protocol_redirect:_&:' \
- -e 's:test_basic_ipv6_proxy:_&:' \
+ sed -e 's:test_basic_ipv6_proxy:_&:' \
-i test/with_dummyserver/test_proxy_poolmanager.py || die
sed -e 's:test_connection_closed_on_read_timeout_preload_false:_&:' \
-i test/with_dummyserver/test_socketlevel.py || die