summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-09 22:00:26 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-09 22:16:46 -0400
commita85276e11d4688a6ca59352c7ebe3ebe72a86955 (patch)
tree1fb72aba8bf39e8de0aadef8e00018f7cf00cc47 /dev-python
parentdev-python/apsw: remove old (diff)
downloadgentoo-a85276e11d4688a6ca59352c7ebe3ebe72a86955.tar.gz
gentoo-a85276e11d4688a6ca59352c7ebe3ebe72a86955.tar.bz2
gentoo-a85276e11d4688a6ca59352c7ebe3ebe72a86955.zip
dev-python/pyjwt: version bump to 1.5.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyjwt/Manifest1
-rw-r--r--dev-python/pyjwt/pyjwt-1.5.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index 15bf24d34436..18e82dd5a211 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1,3 +1,4 @@
DIST PyJWT-1.4.0.tar.gz 34613 SHA256 e1b2386cfad541445b1d43e480b02ca37ec57259fd1a23e79415b57ba5d8a694 SHA512 1664864c0566dbeb1e35c977d30e746c844605e1ce90becda8771c4ff8a8dbad911075f5a41f445d405552b2d61bbb1e86011564027f68c6c4fcd332cf704ff1 WHIRLPOOL 4ebd7291b9a9676559703794acdaf0dd2bd1033dd649ef8068bca85fa7ef6ab444e834910fa78b16c15cf324dd4a470d9b40ecdccdb5fdaca7568ab096dc9a8e
DIST PyJWT-1.5.0.tar.gz 34841 SHA256 fd182b728d13f04c289d9b2623d09256d356c9b4a6778018001454a954d7c54b SHA512 6a811933fc167a5b79a8e0c3cd95154f80e115d50795b4b4593abd95922ff330649b9f6cd8698191c3fb35b27b1b6870702c835eec28306b5349ef8d8d836d04 WHIRLPOOL 1d8a89929ee1e2642fe25054bc15aeaad13eecd283960477f793ad4185b7789c1163f80e6c36597a6593f50cdf9917473c099a706a56423f2d25dee45ab2806a
DIST PyJWT-1.5.2.tar.gz 72715 SHA256 1179f0bff86463b5308ee5f7aff1c350e1f38139d62a723e16fb2c557d1c795f SHA512 8b9b4e5c96e09a1ec4b2e01aa4b81da217d239dc85eafa6634e6371c9ab19c7a95eabbbb98fd92e02ca7921e6fce771596724dcb44f13be93c9e20f09bbf2192 WHIRLPOOL 5797a2c70ceaa1a7092dec33fc74094453891ca40898da66aac3c28f712ee6560596b6b4b6e80bec699c185c67e566d50239c49a28473c924e74bc85d8a3eca1
+DIST PyJWT-1.5.3.tar.gz 73044 SHA256 500be75b17a63f70072416843dc80c8821109030be824f4d14758f114978bae7 SHA512 b25a9f6a04bd072020fcf00bb559b7560902adb79746fb880432c01fa356748238432f53f6b9a21db50ece3e59ed4c45ca3f48ecec0ca3c4095e6a739a5c150c WHIRLPOOL 67ba8da22ffdc62d8f944a20debc8462a0241bbaede565d10b0886b886af41fd56120fd2b0877f7c81edbb08717cc677559a131a54df3d2cf4bce749ed785e30
diff --git a/dev-python/pyjwt/pyjwt-1.5.3.ebuild b/dev-python/pyjwt/pyjwt-1.5.3.ebuild
new file mode 100644
index 000000000000..422c20d2efa0
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-1.5.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1 eutils
+
+MY_PN="PyJWT"
+
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="https://github.com/progrium/pyjwt https://pypi.python.org/pypi/PyJWT/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE=" MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/cryptography-1.4.0[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+python_prepare_all() {
+ find . -name '__pycache__' -prune -exec rm -rf {} \; || die "Cleaning __pycache__ failed"
+ find . -name '*.pyc' -exec rm -f {} \; || die "Cleaing *.pyc failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Available optional features:"
+ optfeature "cryptography" dev-python/cryptography
+ optfeature "flake8" dev-python/flake8
+
+ ewarn "flake8 feature requires 'flake8-import-order' and 'pep8-naming', which are not in portage yet"
+}