summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-28 13:33:29 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-28 14:00:55 +0200
commitad02b5b5ac6d7162c1bdd36f3b41ad8588a0191a (patch)
treecb816032b6689daa9992f98afc27fb88697d3da4 /dev-python
parentdev-python/importlib_metadata: Bump to 1.7.0 (diff)
downloadgentoo-ad02b5b5ac6d7162c1bdd36f3b41ad8588a0191a.tar.gz
gentoo-ad02b5b5ac6d7162c1bdd36f3b41ad8588a0191a.tar.bz2
gentoo-ad02b5b5ac6d7162c1bdd36f3b41ad8588a0191a.zip
dev-python/hypothesis: Bump to 5.18.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.18.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 8d0b41a602c3..4c2402d59592 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -10,3 +10,4 @@ DIST hypothesis-python-5.16.2.tar.gz 9011495 BLAKE2B ecac1ddd0c214a06e8822fc04f9
DIST hypothesis-python-5.16.3.tar.gz 9011952 BLAKE2B d74a68c4ee1e5aacf4be1da5a4656011b0a15f990106c21298101d36e9a097c5dfd165987ad90a45f3a0b74375c4da609cd750f618242b94f34e03b6de0ee866 SHA512 912d984995d4ad8f06e98eb2cc327629328990fc1c072527ce261b637e16622acaf4d0d93928f9dd2d6601ab78f69aa6cf129d5cd7c1c00e50754ebc06957df0
DIST hypothesis-python-5.18.0.tar.gz 9013356 BLAKE2B 3863414e54e40ac5f2a45edbb57fbee058e82f04cbde9eadb99ed6b03a2a2684777b46eabdbe136aea74b835e343485d80cfe98c263afa537c7437e7566f796f SHA512 b1a1f37f1f58a6401a31f32ef0e7de452b8a8bd71fe5aeb72eeac197a23b78c3ff17b61f7940e2a2a755f7f008f0ea3df5b0f2ad5e4c0d2d316bf13dbd7cbdaf
DIST hypothesis-python-5.18.1.tar.gz 9013452 BLAKE2B a513c19a19b3ff49c78d97839dea7d857d9a00f7d42e5e0376cd6fec9ff9a86f9b6b9471da474ec7724e41254105c0ac65fc7d772f01bfc40f6deda200f11629 SHA512 19455699ed50d30767edc5627f797992f2542aeb3ca9e38603a68ffe1108f0287baa183e4dca101f21eaea6c7c7501e135b5baf9e09117a2cae92ec1e437e8b5
+DIST hypothesis-python-5.18.3.tar.gz 9017453 BLAKE2B 85356e723fca66853e388a4a3e791dd4b1cfb80b7a4b62363a4f0d0aeffc44c051eeabd516eebd5737a96050edef978a87788c1141f87aa2e310eda9bf64a0a7 SHA512 baeb4644a90fd8694d88819a46ba1ea6c60ad13e00f07cb923a3d0f43cd4b4d61bd07bf25e45e6d1203f9db44fbe8ec7eca7e029c804659025df89a80520e550
diff --git a/dev-python/hypothesis/hypothesis-5.18.3.ebuild b/dev-python/hypothesis/hypothesis-5.18.3.ebuild
new file mode 100644
index 000000000000..494668bd6a8e
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.18.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}