summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-10-11 19:07:02 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-10-11 19:09:12 +0200
commitb5f312d23839444ad8bf16b3c1577cdc9411d478 (patch)
tree446cda536ee7f47d09bf5ee0e051e58b80eb8a2f /dev-python
parentdev-python/manuel: Stable for amd64+x86. (diff)
downloadgentoo-b5f312d23839444ad8bf16b3c1577cdc9411d478.tar.gz
gentoo-b5f312d23839444ad8bf16b3c1577cdc9411d478.tar.bz2
gentoo-b5f312d23839444ad8bf16b3c1577cdc9411d478.zip
dev-python/manuel: clean up old.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/manuel/Manifest1
-rw-r--r--dev-python/manuel/files/manuel-1.7-rm_zope_test.patch92
-rw-r--r--dev-python/manuel/manuel-1.7.1.ebuild33
3 files changed, 0 insertions, 126 deletions
diff --git a/dev-python/manuel/Manifest b/dev-python/manuel/Manifest
index f0b48b42c365..94bae128a651 100644
--- a/dev-python/manuel/Manifest
+++ b/dev-python/manuel/Manifest
@@ -1,2 +1 @@
-DIST manuel-1.7.1-20130316.tar.bz2 24910 SHA256 4b23c562c84fe771d897b1ce237ba065940ffd5a847bc23bb6ec81070e0d0824 SHA512 94dab56165b92761aa710aba057338ba3062faa375600885e9943e067726ced492493bee5d203883dad604d424f8599fab35fd605e024e2a4139fb5e1a32698e WHIRLPOOL 75909a8fb55f264198733b3b0b0344c5a8e2039e23e55daab2a3dc4aba67ab7d0226ec4197e588a3625cf38062940008ebf0ca8c72a42b8b5077e2e1c38f39dd
DIST manuel-1.8.0.tar.gz 207600 SHA256 a974d7e83652b26be30f6f513fac95d28b9ffa5ae2819a5c63e2ef8594913eb6 SHA512 8099df44cfd28c8ac6256f346bf8cd36091893a38d3c297099866b1a5db97286b9c9e69f3f12054d7eee9ae3985ca0a003d7b2cc082d28d59850bbcad6b57c57 WHIRLPOOL 7870484499d8c18916bf8349ed1a8a9be84eb074440b8c875f3a0468137edf45425a51545da3517a6c81a862708114eea2fa8561eaa219ccb1ff958d8fcb2afe
diff --git a/dev-python/manuel/files/manuel-1.7-rm_zope_test.patch b/dev-python/manuel/files/manuel-1.7-rm_zope_test.patch
deleted file mode 100644
index 3487e5f9a9fa..000000000000
--- a/dev-python/manuel/files/manuel-1.7-rm_zope_test.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-diff -ur manuel-1.7.1.orig/src/manuel/tests.py manuel-1.7.1/src/manuel/tests.py
---- src/manuel/tests.py 2012-04-17 03:08:54.000000000 +0800
-+++ src/manuel/tests.py 2012-05-21 20:43:20.981722893 +0800
-@@ -9,16 +9,17 @@
- import os.path
- import re
- import unittest
--import zope.testing.renormalizing
-
- doctest = manuel.absolute_import('doctest')
-
- here = os.path.dirname(os.path.abspath(__file__))
-
--checker = zope.testing.renormalizing.RENormalizing([
-+try:
-+ checker = zope.testing.renormalizing.RENormalizing([
- (re.compile(r"<unittest\.result\.TestResult"), '<unittest.TestResult'),
- ])
--
-+except:
-+ pass
-
- def turtle_on_the_bottom_test():
- """We use manuel to test itself.
-@@ -52,7 +53,6 @@
- optionflags = doctest.NORMALIZE_WHITESPACE | doctest.ELLIPSIS
-
- m = manuel.ignore.Manuel()
-- m += manuel.doctest.Manuel(optionflags=optionflags, checker=checker)
- m += manuel.codeblock.Manuel()
- m += manuel.capture.Manuel()
- m += manuel.testcase.SectionManuel()
-@@ -66,3 +66,6 @@
- suite,
- doctest.DocTestSuite(),
- ))
-+
-+if __name__ == '__main__':
-+ unittest.TextTestRunner().run(test_suite())
-diff -ur manuel-1.7.1.orig/setup.py manuel-1.7.1/setup.py
---- setup.py 2013-02-14 10:07:38.000000000 +0800
-+++ setup.py 2013-03-15 23:21:18.834849031 +0800
-@@ -21,8 +21,6 @@
- + open('CHANGES.txt').read()
- )
-
--tests_require = ['zope.testing']
--
- setup(
- name='manuel',
- version='1.7.1',
-@@ -38,10 +36,6 @@
- 'Programming Language :: Python :: 3',
- ],
- license='ZPL',
-- extras_require={
-- 'tests': tests_require,
-- },
-- tests_require = tests_require,
- test_suite = 'manuel.tests.test_suite',
- install_requires=[
- 'setuptools',
-diff -ur manuel-1.7.1.orig/src/manuel/index.txt manuel-1.7.1/src/manuel/index.txt
---- src/manuel/index.txt 2012-04-17 03:08:54.000000000 +0800
-+++ src/manuel/index.txt 2012-04-28 05:43:26.918993769 +0800
-@@ -166,16 +166,16 @@
-
- .. code-block:: python
-
-- import os.path
-- import manuel.testing
-+ import os.path
-+ import manuel.testing
-
-- class StripDirsTestCase(manuel.testing.TestCase):
-- def shortDescription(self):
-+ class StripDirsTestCase(manuel.testing.TestCase):
-+ def shortDescription(self):
- return os.path.basename(str(self))
-- suite = manuel.testing.TestSuite(
-- m, path_to_test, TestCase=StripDirsTestCase)
-+ suite = manuel.testing.TestSuite(
-+ m, path_to_test, TestCase=StripDirsTestCase)
-
-- >>> list(suite)[0].shortDescription()
-+ list(suite)[0].shortDescription()
- 'bugs.txt'
-
-
-
-
-
diff --git a/dev-python/manuel/manuel-1.7.1.ebuild b/dev-python/manuel/manuel-1.7.1.ebuild
deleted file mode 100644
index 15e19b1b55b6..000000000000
--- a/dev-python/manuel/manuel-1.7.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Manuel lets you build tested documentation"
-HOMEPAGE="https://github.com/benji-york/manuel/ https://pypi.python.org/pypi/manuel"
-# A snapshot was required since upstream missed out half the source
-SRC_URI="https://dev.gentoo.org/~idella4/tarballs/${P}-20130316.tar.bz2"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-# Required to run tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-DOCS=( CHANGES.txt )
-
-PATCHES=( "${FILESDIR}"/${PN}-1.7-rm_zope_test.patch )
-
-python_test() {
- PYTHONPATH=src/ esetup.py test
-}