summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-02 08:53:01 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-02 08:53:01 +0100
commitb626ca718f4736db3dcdef09cf465dab65ef13a1 (patch)
treee94745670516c5748d70da030e4c32056e866f66 /dev-python
parentnet-analyzer/scapy: Drop unnecessary usage of DISTUTILS_SINGLE_IMPL (diff)
downloadgentoo-b626ca718f4736db3dcdef09cf465dab65ef13a1.tar.gz
gentoo-b626ca718f4736db3dcdef09cf465dab65ef13a1.tar.bz2
gentoo-b626ca718f4736db3dcdef09cf465dab65ef13a1.zip
dev-python/django: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django/Manifest1
-rw-r--r--dev-python/django/django-1.9.ebuild111
-rw-r--r--dev-python/django/files/django-1.9-bashcomp.patch46
3 files changed, 158 insertions, 0 deletions
diff --git a/dev-python/django/Manifest b/dev-python/django/Manifest
index 4c3728988c2a..08ed8fe2495c 100644
--- a/dev-python/django/Manifest
+++ b/dev-python/django/Manifest
@@ -3,3 +3,4 @@ DIST Django-1.5.12.tar.gz 8202839 SHA256 b3de77beb6e59b72071ca66f20c2ad34e1b90d3
DIST Django-1.6.11.tar.gz 6764000 SHA256 7e50e573e484435873b3515d7982d80093b2695aba17fd0ff024307454dc3a56 SHA512 de6024b49e0344bf153f73ec344180fb701e415e4f9c330118821744d0e579436cc265724f7ef7213c9551847022ba9570312633f317b9003db533d06deb9829 WHIRLPOOL 5de086952bda9449f85798e8fe3bac82f11e1b856c1d39e340399e71ca6bf183318eebf1f536714567036485637166a929082a1ba9d6c1816f07c53dcc12c72a
DIST Django-1.7.11.tar.gz 7586798 SHA256 2039144fce8f1b603d03fa5a5643578df1ad007c4ed41a617f02a3943f7059a1 SHA512 2e3415295ee6b590e366b09adb261baccb750519b9bcef1bb09bd52a2db705c8082bfc13440c621a5f41dd4f9bd626792eba4a572e78de3b7caf93c951c406ee WHIRLPOOL 8797862021c6acdfcba5752f6f5f2d567a564812fc5089678a9d00b9d8f1cb13c03bd0cb9b369b68ce1d1f1dc1522f05d41778f5181aef9c7d49783afc280e7c
DIST Django-1.8.7.tar.gz 7276831 SHA256 17a66de5cf59b5ee81c3dc57609b145bb45adddc0dc06937b998597d6e7b4523 SHA512 74b89efd4fd2d19542a30e0fa0648652aa85ea309804afadae1162b1cac3492e599beaf5ea868d67bcef5f016283952dcc869726cbf6f15141f0816a0377b041 WHIRLPOOL adae3d00ceab8bb3e526107068270d53de968b782d5e37a64f59ecaf75e8933d3895dc6de5c934ea180c8436a88acb4949f7f4f8bba56c13c92d08874596c784
+DIST Django-1.9.tar.gz 7392116 SHA256 05fe4b19a8778d4b48bbf1f4dfca3106881fea7982664553e7f7f861606f7c66 SHA512 255438e4ce89bc128506ef9137604cd38bc7cd5f69b687e9ec6c9332b7a89b55cc904209b630e42e0376cca944a26090da9b209ea2ecaaf0033ee5e8c9e0378d WHIRLPOOL d1ae1b62c7e3966dbef4191910970db3d83b5a6693528adb2966b00f0a599b7674689230e6d2875ea9fd44e0926ab0d98a303b45c61c1bb9a7e54555fd7a1cb7
diff --git a/dev-python/django/django-1.9.ebuild b/dev-python/django/django-1.9.ebuild
new file mode 100644
index 000000000000..a435541b39f7
--- /dev/null
+++ b/dev-python/django/django-1.9.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+PYTHON_REQ_USE='sqlite?,threads(+)'
+WEBAPP_NO_AUTO_INSTALL="yes"
+
+inherit bash-completion-r1 distutils-r1 eutils versionator webapp
+
+MY_PN="Django"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="http://www.djangoproject.com/ https://pypi.python.org/pypi/Django"
+SRC_URI="
+ https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz
+ mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
+ "
+
+LICENSE="BSD"
+# admin fonts: Roboto (media-fonts/roboto)
+LICENSE+=" Apache-2.0"
+# admin icons, jquery, xregexp.js
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc sqlite test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
+ test? (
+ ${PYTHON_DEPS//sqlite?/sqlite}
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/numpy[$(python_gen_usedep 'python*')]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-bashcomp.patch
+)
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+python_prepare_all() {
+ # Prevent d'loading in the doc build
+ sed -e '/^ "sphinx.ext.intersphinx",/d' -i docs/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Tests have non-standard assumptions about PYTHONPATH,
+ # and don't work with ${BUILD_DIR}/lib.
+ PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v2 \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp extras/django_bash_completion ${PN}-admin
+ bashcomp_alias ${PN}-admin django-admin.py
+
+ if use doc; then
+ rm -fr docs/_build/html/_sources || die
+ local HTML_DOCS=( docs/_build/html/. )
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r django/contrib/admin/static/admin/.
+ distutils-r1_python_install_all
+}
+
+src_install() {
+ distutils-r1_src_install
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "Additional Backend support can be enabled via"
+ optfeature "MySQL backend support in python 2.7 only" dev-python/mysql-python
+ optfeature "MySQL backend support in python 2.7 - 3.4" dev-python/mysqlclient
+ optfeature "PostgreSQL backend support" dev-python/psycopg:2
+ echo ""
+ elog "Other features can be enhanced by"
+ optfeature "GEO Django" sci-libs/gdal[geos]
+ optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
+ optfeature "ImageField Support" dev-python/pillow
+ optfeature "Password encryption" dev-python/bcrypt
+ optfeature "High-level abstractions for Django forms" dev-python/django-formtools
+ echo ""
+ elog "A copy of the admin media is available to webapp-config for installation in a"
+ elog "webroot, as well as the traditional location in python's site-packages dir"
+ elog "for easy development."
+ webapp_pkg_postinst
+}
diff --git a/dev-python/django/files/django-1.9-bashcomp.patch b/dev-python/django/files/django-1.9-bashcomp.patch
new file mode 100644
index 000000000000..8618dbef920d
--- /dev/null
+++ b/dev-python/django/files/django-1.9-bashcomp.patch
@@ -0,0 +1,46 @@
+ extras/django_bash_completion | 35 +----------------------------------
+ 1 file changed, 1 insertion(+), 34 deletions(-)
+
+diff --git a/extras/django_bash_completion b/extras/django_bash_completion
+index 06a2321..abe76e5 100755
+--- a/extras/django_bash_completion
++++ b/extras/django_bash_completion
+@@ -37,37 +37,4 @@ _django_completion()
+ COMP_CWORD=$COMP_CWORD \
+ DJANGO_AUTO_COMPLETE=1 $1 ) )
+ }
+-complete -F _django_completion -o default django-admin.py manage.py django-admin
+-
+-_python_django_completion()
+-{
+- if [[ ${COMP_CWORD} -ge 2 ]]; then
+- local PYTHON_EXE=${COMP_WORDS[0]##*/}
+- echo $PYTHON_EXE | egrep "python([2-9]\.[0-9])?" >/dev/null 2>&1
+- if [[ $? == 0 ]]; then
+- local PYTHON_SCRIPT=${COMP_WORDS[1]##*/}
+- echo $PYTHON_SCRIPT | egrep "manage\.py|django-admin(\.py)?" >/dev/null 2>&1
+- if [[ $? == 0 ]]; then
+- COMPREPLY=( $( COMP_WORDS="${COMP_WORDS[*]:1}" \
+- COMP_CWORD=$(( COMP_CWORD-1 )) \
+- DJANGO_AUTO_COMPLETE=1 ${COMP_WORDS[*]} ) )
+- fi
+- fi
+- fi
+-}
+-
+-# Support for multiple interpreters.
+-unset pythons
+-if command -v whereis &>/dev/null; then
+- python_interpreters=$(whereis python | cut -d " " -f 2-)
+- for python in $python_interpreters; do
+- [[ $python != *-config ]] && pythons="${pythons} ${python##*/}"
+- done
+- unset python_interpreters
+- pythons=$(echo $pythons | tr " " "\n" | sort -u | tr "\n" " ")
+-else
+- pythons=python
+-fi
+-
+-complete -F _python_django_completion -o default $pythons
+-unset pythons
++complete -F _django_completion -o default django-admin.py django-admin