summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-09-03 20:11:36 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-09-03 20:11:36 -0400
commitb655830169a85a378ffd745c841676e10183c14f (patch)
tree9e95eec4f1e852cca26b10c4d92d33ea619d3c76 /dev-python
parentdev-python/pypax: add 9999 version. (diff)
downloadgentoo-b655830169a85a378ffd745c841676e10183c14f.tar.gz
gentoo-b655830169a85a378ffd745c841676e10183c14f.tar.bz2
gentoo-b655830169a85a378ffd745c841676e10183c14f.zip
dev-python/pypax: version bump 0.9.1
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypax/Manifest1
-rw-r--r--dev-python/pypax/pypax-0.9.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pypax/Manifest b/dev-python/pypax/Manifest
index 71ba474647dc..66009d68e445 100644
--- a/dev-python/pypax/Manifest
+++ b/dev-python/pypax/Manifest
@@ -1,2 +1,3 @@
DIST elfix-0.8.4.tar.gz 374742 SHA256 374be66da3dddef485bbb5e95bfcab6fd0c2db478255bddd10079730ada5260b SHA512 10aacc3fff33c934e2d4487d174a2b0cec10ffb7a35fc72b160c786f82f0355f3a2dea716bc7fb929d2919cc32a26844f37f9d73064b755098bdaa72e8075bda WHIRLPOOL b04e099f188c0b76d8c07abd76559c1313854aa83a03ad69afb72674d93cde6ce538ae10d0fea3be5495937e72a4b98fdd36efbb2e3aa8ff23c1d9f7f943c1ae
DIST elfix-0.9.0.tar.gz 372014 SHA256 8b547d987edb2f7dc23ddf30f959d7d051a9ed49810f983b8fe6c489fe731cf0 SHA512 fd9bab90d745f77429c902acd2a14f615132731b3c38929dce764f1e5f7ee8f6478a6fef7ce0cb38e7ebd9181ba57965ff0c97da5e01d0fbf2cfb940ed691ebf WHIRLPOOL c09fa2193b990a506cae17f370ec10fa6302e17d2a165e42eceb88644f8a92e297c839ad788204e213d8205695b65557a7dcef5f6417177c434c8d0a34bd5eb7
+DIST elfix-0.9.1.tar.gz 398588 SHA256 0368d07bfdad4a14f039929a30d85a612dcd9d22ac87211f8e59d452bac23625 SHA512 28fdde7841263cee766434b5eda1a4151999526aa3a1acaacd2e6355502df4b56db9faf64ce81bdc89606d366d0a6dd28c5c135290fe7f0285cee480f6002527 WHIRLPOOL cd7dc6e191d97836f4b8859b73777e3b4b6fce5d290087400327f87a621e9879f5c233eef51bef981398d0d00ecc753f222655108994d25a4e0503799569ec82
diff --git a/dev-python/pypax/pypax-0.9.1.ebuild b/dev-python/pypax/pypax-0.9.1.ebuild
new file mode 100644
index 000000000000..2b2ef718c083
--- /dev/null
+++ b/dev-python/pypax/pypax-0.9.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
+ inherit git-2
+else
+ SRC_URI="https://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+ S="${WORKDIR}/elfix-${PV}"
+fi
+
+DESCRIPTION="Python module to get or set either PT_PAX and/or XATTR_PAX flags"
+HOMEPAGE="https://dev.gentoo.org/~blueness/elfix/
+ https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+ptpax +xtpax"
+
+REQUIRED_USE="|| ( ptpax xtpax )"
+
+RDEPEND="
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"
+
+src_compile() {
+ cd scripts
+ unset PTPAX
+ unset XTPAX
+ use ptpax && export PTPAX="yes"
+ use xtpax && export XTPAX="yes"
+ distutils-r1_src_compile
+}
+
+src_install() {
+ cd scripts
+ distutils-r1_src_install
+}