summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-18 18:09:55 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-18 18:09:55 -0500
commitb78829d20e5c3594bea706dc906bf2c9d4e79830 (patch)
tree947ea231692e449fc83ff93f7b7676abebc6ad90 /dev-python
parentdev-python/python-octaviaclient: 2.2.0 bump (diff)
downloadgentoo-b78829d20e5c3594bea706dc906bf2c9d4e79830.tar.gz
gentoo-b78829d20e5c3594bea706dc906bf2c9d4e79830.tar.bz2
gentoo-b78829d20e5c3594bea706dc906bf2c9d4e79830.zip
dev-python/python-saharaclient: 3.2.1 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-saharaclient/Manifest1
-rw-r--r--dev-python/python-saharaclient/python-saharaclient-3.2.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-saharaclient/Manifest b/dev-python/python-saharaclient/Manifest
index e73ae889f165..ac1c564ea370 100644
--- a/dev-python/python-saharaclient/Manifest
+++ b/dev-python/python-saharaclient/Manifest
@@ -1 +1,2 @@
DIST python-saharaclient-2.2.1.tar.gz 111417 BLAKE2B b4545a161a630caabca9318eb0ead796b417d686cdf2c134f7e8022e3e62e7b01e5db7cff1950826d49798d6e6ea41334138bcf918dfb23a2eaf6527c0788fde SHA512 f5ebbe76d00a9bab4239bc19df2bde30b133b261bf8abb63db12cde9539c5bc92fb1a24b6c9ed6e8a509a44ae2abe98f5e8b74655517a1e2c2126938cc5c517f
+DIST python-saharaclient-3.2.1.tar.gz 106266 BLAKE2B a9f439028ae523a452b5cdc0024e4d44527c3114826432cef837df1c32bbd89035ec09c8f72c349e7fc8347d438236b61e20df253119bf35bf69e27b00c2affa SHA512 a0e9dec4a8a1b86de182535060c99d79c7aa4c93f801088a0b7d6a40084294821c22de531b00cf73b4f6940e72dc43e505bea8aee218fdcb63ef0727aa806544
diff --git a/dev-python/python-saharaclient/python-saharaclient-3.2.1.ebuild b/dev-python/python-saharaclient/python-saharaclient-3.2.1.ebuild
new file mode 100644
index 000000000000..b81682988724
--- /dev/null
+++ b/dev-python/python-saharaclient/python-saharaclient-3.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client for the OpenStack Sahara API, aka HADOOP"
+HOMEPAGE="https://github.com/openstack/python-saharaclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"