summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-11-25 09:41:11 +0100
committerMichał Górny <mgorny@gentoo.org>2018-11-25 10:08:55 +0100
commitb789738aacb59663ef075ce5598f0fd83343d629 (patch)
tree5c1311de6aa2b72c17be99bc267fbb3194bc22fe /dev-python
parentsys-auth/pam_p11: fix formatting (diff)
downloadgentoo-b789738aacb59663ef075ce5598f0fd83343d629.tar.gz
gentoo-b789738aacb59663ef075ce5598f0fd83343d629.tar.bz2
gentoo-b789738aacb59663ef075ce5598f0fd83343d629.zip
dev-python/pycparser: Drop old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycparser/Manifest1
-rw-r--r--dev-python/pycparser/pycparser-2.17.ebuild42
2 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/pycparser/Manifest b/dev-python/pycparser/Manifest
index a9b5042d377c..a8c8f9d21435 100644
--- a/dev-python/pycparser/Manifest
+++ b/dev-python/pycparser/Manifest
@@ -1,3 +1,2 @@
DIST pycparser-2.14.tar.gz 223295 BLAKE2B 13dd4e36d7239db4fd6dfb77f08088bdbffa897ab75d748da5bd7297fe0a7dd751ba7153f8bf15f93494e347c653d1ebc7250907d2ccc555e785830e731e93dc SHA512 d5b9ab434a8944898ac23a4f51189db77b02b993bf3e3ca018852b117fc0eb43e460b156beaa5c1d631ad71c81e1649113e9fff7e33506b1e7d4de24d8b464c6
-DIST pycparser-2.17.tar.gz 231163 BLAKE2B b264fbdf235f63559c96d103ca42fd0faf2c5e125420e75503e7dc2cc6e86a23347b9070a33b1e28721b919d89d0281b69b04c2761b180fa535c748933392172 SHA512 c9caaa8d256748e0623d077b11931abb38d19367136c70a835f7587e1f7ceb64f3acb7a983dcb68bedd2cf187517762a5753844e8ed58d1d9ed6f364c55839b4
DIST pycparser-2.18.tar.gz 245897 BLAKE2B 2f47263c73763f9d76edcb0d90aacd2e6cf0a68ed2e8c5825a0788a5ccb6574167220a5bb7605b2c11dda8956ce8fb1ad28eeb8e91fed7aa0282191b11478b63 SHA512 4754e4e7556d21da328bf7dbabf72f940c9b18f1457260d48208033b05e576919f45ab399e86ea49e82120116980d7d6f53e8b959d21b7b03a3b5bbea3672f13
diff --git a/dev-python/pycparser/pycparser-2.17.ebuild b/dev-python/pycparser/pycparser-2.17.ebuild
deleted file mode 100644
index ba18c49470cd..000000000000
--- a/dev-python/pycparser/pycparser-2.17.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="C parser and AST generator written in Python"
-HOMEPAGE="https://github.com/eliben/pycparser"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
-IUSE="test"
-
-RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-pkg_pretend() {
- if has_version "=dev-python/pycparser-2.16"; then
- eerror "You have a broken version of dev-python/pycparser installed."
- eerror "Please remove the broken version before continuing."
- eerror "eg. emerge --unmerge =dev-python/pycparser-2.16"
- die "Broken dev-python/pycparser"
- fi
-}
-
-python_compile() {
- distutils-r1_python_compile
- pushd "${BUILD_DIR}/lib/pycparser" > /dev/null || die
- "${PYTHON}" _build_tables.py || die
- popd > /dev/null || die
-}
-
-python_test() {
- nosetests || die
-}