summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-20 23:08:31 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-23 20:30:41 +0200
commitbd4b92d16b883879219696355f1b8c2fb9e0eb49 (patch)
treebf92cb2981702912df594cf9584fa2e036da1236 /dev-python
parentsys-devel/llvm: Dedupe with new eclass code (diff)
downloadgentoo-bd4b92d16b883879219696355f1b8c2fb9e0eb49.tar.gz
gentoo-bd4b92d16b883879219696355f1b8c2fb9e0eb49.tar.bz2
gentoo-bd4b92d16b883879219696355f1b8c2fb9e0eb49.zip
dev-python/lit: Dedupe with new eclass code
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/lit/lit-10.0.1.9999.ebuild6
-rw-r--r--dev-python/lit/lit-10.0.1_rc1.ebuild6
-rw-r--r--dev-python/lit/lit-11.0.0.9999.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/lit/lit-10.0.1.9999.ebuild b/dev-python/lit/lit-10.0.1.9999.ebuild
index c9394c7a1190..b9123ef7bf14 100644
--- a/dev-python/lit/lit-10.0.1.9999.ebuild
+++ b/dev-python/lit/lit-10.0.1.9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python2_7 python3_{6..9} )
-inherit distutils-r1 llvm.org multiprocessing
+inherit distutils-r1 llvm.org
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
@@ -34,6 +34,6 @@ src_prepare() {
python_test() {
local -x LIT_PRESERVES_TMP=1
- ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
- -vv tests || die
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
}
diff --git a/dev-python/lit/lit-10.0.1_rc1.ebuild b/dev-python/lit/lit-10.0.1_rc1.ebuild
index c9394c7a1190..b9123ef7bf14 100644
--- a/dev-python/lit/lit-10.0.1_rc1.ebuild
+++ b/dev-python/lit/lit-10.0.1_rc1.ebuild
@@ -6,7 +6,7 @@ EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python2_7 python3_{6..9} )
-inherit distutils-r1 llvm.org multiprocessing
+inherit distutils-r1 llvm.org
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
@@ -34,6 +34,6 @@ src_prepare() {
python_test() {
local -x LIT_PRESERVES_TMP=1
- ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
- -vv tests || die
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
}
diff --git a/dev-python/lit/lit-11.0.0.9999.ebuild b/dev-python/lit/lit-11.0.0.9999.ebuild
index c9394c7a1190..b9123ef7bf14 100644
--- a/dev-python/lit/lit-11.0.0.9999.ebuild
+++ b/dev-python/lit/lit-11.0.0.9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python2_7 python3_{6..9} )
-inherit distutils-r1 llvm.org multiprocessing
+inherit distutils-r1 llvm.org
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
@@ -34,6 +34,6 @@ src_prepare() {
python_test() {
local -x LIT_PRESERVES_TMP=1
- ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
- -vv tests || die
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
}