summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-14 19:20:24 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-14 19:20:24 +0200
commitbdcd4d5b9182a23980507d42ff800389cd4404a6 (patch)
tree4c40214753eaac75190e3c549d9ed99e0e71d166 /dev-python
parentsci-chemistry/gromacs: Version bump (diff)
parentdev-python/pytest-cov: Version bump to 2.2.0, add python3_5 target (diff)
downloadgentoo-bdcd4d5b9182a23980507d42ff800389cd4404a6.tar.gz
gentoo-bdcd4d5b9182a23980507d42ff800389cd4404a6.tar.bz2
gentoo-bdcd4d5b9182a23980507d42ff800389cd4404a6.zip
dev-python/*: Merge pytest-cov version bump + py3.5 for deps
Pull-Request: https://github.com/gentoo/gentoo/pull/183
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/apipkg/apipkg-1.4.ebuild2
-rw-r--r--dev-python/cov-core/cov-core-1.15.0.ebuild2
-rw-r--r--dev-python/execnet/execnet-1.4.1.ebuild2
-rw-r--r--dev-python/hgdistver/hgdistver-0.25.ebuild2
-rw-r--r--dev-python/process-tests/process-tests-1.1.2.ebuild2
-rw-r--r--dev-python/pytest-cache/pytest-cache-1.0.ebuild2
-rw-r--r--dev-python/pytest-capturelog/pytest-capturelog-0.7.ebuild2
-rw-r--r--dev-python/pytest-cov/Manifest1
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.2.0.ebuild37
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild2
10 files changed, 46 insertions, 8 deletions
diff --git a/dev-python/apipkg/apipkg-1.4.ebuild b/dev-python/apipkg/apipkg-1.4.ebuild
index 19c4063a159b..787aedea05da 100644
--- a/dev-python/apipkg/apipkg-1.4.ebuild
+++ b/dev-python/apipkg/apipkg-1.4.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy pypy3 )
inherit distutils-r1
diff --git a/dev-python/cov-core/cov-core-1.15.0.ebuild b/dev-python/cov-core/cov-core-1.15.0.ebuild
index 1fe596a9b51b..fc38a645d1fd 100644
--- a/dev-python/cov-core/cov-core-1.15.0.ebuild
+++ b/dev-python/cov-core/cov-core-1.15.0.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy pypy3 )
inherit distutils-r1
DESCRIPTION="plugin core for use by pytest-cov, nose-cov and nose2-cov"
diff --git a/dev-python/execnet/execnet-1.4.1.ebuild b/dev-python/execnet/execnet-1.4.1.ebuild
index 7e5cad3119e4..3ecca0265cf3 100644
--- a/dev-python/execnet/execnet-1.4.1.ebuild
+++ b/dev-python/execnet/execnet-1.4.1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy pypy3 )
inherit distutils-r1
diff --git a/dev-python/hgdistver/hgdistver-0.25.ebuild b/dev-python/hgdistver/hgdistver-0.25.ebuild
index e05a6088409b..7443a610658e 100644
--- a/dev-python/hgdistver/hgdistver-0.25.ebuild
+++ b/dev-python/hgdistver/hgdistver-0.25.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy pypy3 )
inherit distutils-r1
diff --git a/dev-python/process-tests/process-tests-1.1.2.ebuild b/dev-python/process-tests/process-tests-1.1.2.ebuild
index ed80beb0b9b4..5413f2d28adf 100644
--- a/dev-python/process-tests/process-tests-1.1.2.ebuild
+++ b/dev-python/process-tests/process-tests-1.1.2.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1
diff --git a/dev-python/pytest-cache/pytest-cache-1.0.ebuild b/dev-python/pytest-cache/pytest-cache-1.0.ebuild
index 6cf0b751da4b..1aaa5acb094e 100644
--- a/dev-python/pytest-cache/pytest-cache-1.0.ebuild
+++ b/dev-python/pytest-cache/pytest-cache-1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1
diff --git a/dev-python/pytest-capturelog/pytest-capturelog-0.7.ebuild b/dev-python/pytest-capturelog/pytest-capturelog-0.7.ebuild
index 925df1f5c417..f82ae057c17c 100644
--- a/dev-python/pytest-capturelog/pytest-capturelog-0.7.ebuild
+++ b/dev-python/pytest-capturelog/pytest-capturelog-0.7.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy pypy3 )
inherit distutils-r1
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index c8d88b6ccf1c..6ea734d5dd12 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,3 +1,4 @@
DIST pytest-cov-1.6.tar.gz 8257 SHA256 2e803c89f11e0344111670349f6ef401f831e85cbd287b0c5d61917da5aac454 SHA512 36c18e8e731613f2412e8e377f1911704d4af23a82fe66b822547850c3343204f682d3464c97f2cb4360f5090e7a58e5ac9679e83ae90adc0ccdb5b0e467430f WHIRLPOOL 41543b2e7f61d61d754bfef4c307fc135ab0d69b10d9e057f64bd3f4cacbc6e47316e478dbd797dd7aea0a8360bad5cc183214c742c749991fd5fe73b96503f2
DIST pytest-cov-1.8.1.tar.gz 8649 SHA256 31e5198c06f290e1e813d30ddd063a0401d9e3a698129ca44267781673a71285 SHA512 dff6c6345bdc2d219800782d7acb3d301c8d67314f0f4af983daa0942a8c97768a2ce6c64f11529a3d8d876c218c62dbf08b7a63cc7345072e70bbc85ad4d112 WHIRLPOOL 90f024e0388323a5d1bd8ffd439c3c6cfb242ac2f539d391f4139a6ab2e251c6ff01831e9a261506d2c1552f1beeacc99db43d3b98a3663828083fec1ae722f8
DIST pytest-cov-2.1.0.tar.gz 25992 SHA256 6e86c3ae3be9930fa3f1402651819b00169fb5e963d29ed03d390d152a608506 SHA512 f763e611b19f6769183583d275e28467f7cc5cc8a8fe5a4d3eb798ddf8d4e008732ec8c29b757aaf0fba0f5a660d92729499f3d388693f631ba73cc7a570d738 WHIRLPOOL 1ece60dea2fc1ff2da342313a0e67ee63a63cf35ece930f92b59c2283522698df0be4c10fb6951d3afff9fb1acffd37d207dcc4f0400109cb4f8c830d69a5857
+DIST pytest-cov-2.2.0.tar.gz 29965 SHA256 2231d43f07760d6904dadceabca53ab16ef95ba58fff393861b64c0cab96c9d1 SHA512 3e6a2b648b12eff3d8f0aad12dda35a05820f6073e7f87e9c92ed6cca00fe031750da8f6c37eb81cf6ca7b2e4975dafffd7e3e901cb7b91e5c53c83b6e6b8420 WHIRLPOOL 9feff5557af5f4101e9ae508febf3479472781544b54345d5f53f0f19df5f40eb5af4ada2b44037f590445761ee9d3bffe14d729c465f880951d714eeb6ae491
diff --git a/dev-python/pytest-cov/pytest-cov-2.2.0.ebuild b/dev-python/pytest-cov/pytest-cov-2.2.0.ebuild
new file mode 100644
index 000000000000..0ff2fc05655f
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-2.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.python.org/pypi/pytest-cov"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pytest-capturelog[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
+ py.test -p pytest_cov -vvx || die
+}
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
index d6fc2826fc9e..8eb076c307f9 100644
--- a/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
+++ b/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1