summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-29 08:51:47 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-29 08:53:22 +0200
commitbfa55b84bbd4da3e21b73fdebd517bc246ff6a0b (patch)
treea7838fa5bf51a78d1a5696d1798255902162c2a1 /dev-python
parentmedia-libs/libcddb: Fixed build with CONFIG_SHELL != bash (diff)
downloadgentoo-bfa55b84bbd4da3e21b73fdebd517bc246ff6a0b.tar.gz
gentoo-bfa55b84bbd4da3e21b73fdebd517bc246ff6a0b.tar.bz2
gentoo-bfa55b84bbd4da3e21b73fdebd517bc246ff6a0b.zip
dev-python/tqdm: Bump to 4.47.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.47.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 28b3a53c9ad6..250d86e8b5ef 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -4,3 +4,4 @@ DIST tqdm-4.40.0.tar.gz 129225 BLAKE2B 85030c11bdba6c1d6da461e3c648bae6ae173577f
DIST tqdm-4.45.0.tar.gz 140990 BLAKE2B 8699b3a820859406e9bbafaaa48ba1b418e3083898d2b6c3401078996dd03431db259d5ad8a377226a50b80513ef0fc55bdaf2b67fc4a2bdd490bc5fdc04d681 SHA512 7b35f86205c6581ede9bdb0788e7f55be525c3f0f77952803046661c6a7a6cd3c15ed0323376ecedb5cddace1b32a41fee1932033dcaa49f9096dc3b9b674f10
DIST tqdm-4.46.0.tar.gz 144312 BLAKE2B 93b902d9a362e658f244f3c1b15a3496425cb3e401adf291dc0a9c7c0bd551baa1171a753be8d1c3b877d2cd3ab25e81dddbd8492668d0b0f6ca3cb47d13be1c SHA512 ccdfce4d273e78ced172fc3edb24ac038465169f7b765e7bf779831ef3d0dc72c648c5fb165aba02e0c6dc86c5d0ea3d93d5530b642ddd84e3d284c7354739cf
DIST tqdm-4.46.1.tar.gz 144383 BLAKE2B 4d72bfbf0c225c779ae2c9bf405f9effdb69cfe7862325b12e8408c17a03b7a87f9cf0d055de598a67132861114c89b237d0ad2509302e452cc67ce9aa34fa48 SHA512 de8710ceb44b6caa073aaa3c9dca281880d752d1b542a3dd87a54884478a185c35ab1969c6cb7242e30ee0511f967cde7bd4fa83a8d4f8c58d3e95ad2bf3bfc6
+DIST tqdm-4.47.0.tar.gz 145749 BLAKE2B 77a5efec763a8e58e071ee571077ee0db72d9243308592519ecd2c38f60d6b621fd7362dd87bdd0759a39f25c19cc3cc889e9a8376dc658ed565ca7e19fc68cd SHA512 4023988cef757f43a6f59f7eddc8f40246cbca4994cea91dbb4a788385c0706f376f4c0fd5c8c47146c10eb8c52be2c9d4855b7bea0a5036162c55447aac95d7
diff --git a/dev-python/tqdm/tqdm-4.47.0.ebuild b/dev-python/tqdm/tqdm-4.47.0.ebuild
new file mode 100644
index 000000000000..563276f5d141
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.47.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8,9}} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ sed -r \
+ -e "s:'nose'(,[[:space:]]*|)::" \
+ -e "s:'flake8'(,[[:space:]]*|)::" \
+ -e "s:'coverage'(,[[:space:]]*|)::" \
+ -i setup.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # tests_main.py requires the package to be installed
+ distutils_install_for_testing
+ # Skip unpredictable performance tests
+ nosetests tqdm -v --ignore 'tests_perf.py' \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install --skip-build
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}