summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-02-28 23:12:17 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-02-28 23:12:17 +0700
commitc5c7338a361a4ccc32760a638cb4841d74925c61 (patch)
tree2aae1a9210a70dae0a2038adb17b3809ff3caeb2 /dev-python
parentdev-python/inflect: bump to 4.1.0 (diff)
downloadgentoo-c5c7338a361a4ccc32760a638cb4841d74925c61.tar.gz
gentoo-c5c7338a361a4ccc32760a638cb4841d74925c61.tar.bz2
gentoo-c5c7338a361a4ccc32760a638cb4841d74925c61.zip
dev-python/spyder: add version restrictions from dependencies.py
Closes: https://bugs.gentoo.org/show_bug.cgi?id=711024 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/spyder/spyder-4.0.1-r1.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/dev-python/spyder/spyder-4.0.1-r1.ebuild b/dev-python/spyder/spyder-4.0.1-r1.ebuild
index 438470ebe1eb..43bba250f2c4 100644
--- a/dev-python/spyder/spyder-4.0.1-r1.ebuild
+++ b/dev-python/spyder/spyder-4.0.1-r1.ebuild
@@ -23,29 +23,31 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
- dev-python/atomicwrites[${PYTHON_USEDEP}]
+ >=dev-python/atomicwrites-1.2.0[${PYTHON_USEDEP}]
>=dev-python/chardet-2.0.0[${PYTHON_USEDEP}]
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/diff-match-patch[${PYTHON_USEDEP}]
+ >=dev-python/cloudpickle-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/diff-match-patch-20181111[${PYTHON_USEDEP}]
dev-python/intervaltree[${PYTHON_USEDEP}]
~dev-python/jedi-0.14.1[${PYTHON_USEDEP}]
dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/nbconvert[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pickleshare[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-4.0[${PYTHON_USEDEP}]
+ >=dev-python/numpydoc-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pexpect-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pickleshare-0.4[${PYTHON_USEDEP}]
+ >=dev-python/psutil-0.3[${PYTHON_USEDEP}]
>=dev-python/pygments-2.0[${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
+ >=dev-python/pylint-0.25[${PYTHON_USEDEP}]
>=dev-python/python-language-server-0.31.2[${PYTHON_USEDEP}]
+ <dev-python/python-language-server-0.32.0[${PYTHON_USEDEP}]
>=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
- dev-python/pyzmq[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17.0.0[${PYTHON_USEDEP}]
>=dev-python/qdarkstyle-2.7[${PYTHON_USEDEP}]
>=dev-python/qtawesome-0.5.7[${PYTHON_USEDEP}]
>=dev-python/qtconsole-4.6.0[${PYTHON_USEDEP}]
>=dev-python/QtPy-1.5.0[${PYTHON_USEDEP},svg,webengine]
- dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-0.6.6[${PYTHON_USEDEP}]
>=dev-python/spyder-kernels-1.8.1[${PYTHON_USEDEP}]
+ <dev-python/spyder-kernels-2.0.0[${PYTHON_USEDEP}]
dev-python/watchdog[${PYTHON_USEDEP}]"
DEPEND="test? (